HD 1016 Prime Ring Problem(素数环问题)

题目来源 :HD 1016

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
题意就是输入一个数n,在 1 到 n 里面找数字围成一个圈,使得相邻的两个数字加起来是素数,每个环都有1,输出的结果按字典序输出,每个答案都从1 开始。

这里有一个值得注意的地方就是,最后一个数跟1的和要是素数。每个case之后都要有空行。

很显然,要用for循环进行深搜。

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <iostream>
using namespace std;

int num[20],ans[20],bj[20];
int n,len;
void get(){    //这里是得到素数,如果一个个判断素数,会做很多重复的工作
	len=0;
	int leap,i,j;
	for(j=2;j<25;j++){
		leap=0;
		int ma=sqrt(j)+1;
		for(i=2;i<ma;i++){
			
		if(j%i==0) {
			leap=1;break;
		}
	}
	if(!leap)
		num[len++]=j;
	}
}

int prim(int a){
	for(int i=0;i<len;i++)
	if(a==num[i]) return 1;
	return 0;
}

int dfs(int pre,int ord,int k){
	
	if(!prim(pre+ord)) return 0;
	ans[k]=ord;

       if(k==n&&prim(ord+1)){
	for(int i=1;i<n;i++)
	printf("%d ",ans[i]);
	printf("%d\n",ans[n]);
		return 1;
	}
	bj[ord]=1;
	for(int i=2;i<=n;i++)
	if(bj[i]==0&&dfs(ord,i,k+1))
		break;				
	bj[ord]=0;
	return 0;
}

int main(){
	int cc=1;
	get();
	while(scanf("%d",&n)!=EOF){
		printf("Case %d:\n",cc++);
	      if(n==1){
        printf("1\n");
        continue;
        }
		memset(bj,0,sizeof(bj));
		ans[1]=1;
		for(int i=2;i<=n;i++)    
		dfs(1,i,2);
		printf("\n");
	}
	return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值