1038 Recover the Smallest Number (30 分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤104) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

思路解析: 

采用贪心算法,对于两个数字串a和数字串b,按照a+b和b+a比较大小的结果,对a和b进行排序,之后,在一个一个数字串输出,需要注意,输出的第一个字符不能为零。同时需要考虑所有字符串的数值均为零的情况,此时输出结果为0.

 代码:

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
struct segment
{
    char number[10];
}num[10010];
bool cmp(segment a,segment b)//比较函数
{
    char A[20],B[20];
    int len=0;
    for(int i=0;i<(int )strlen(a.number);i++)
        A[len++]=a.number[i];
    for(int i=0;i<(int )strlen(b.number);i++)
        A[len++]=b.number[i];
    len=0;
    for(int i=0;i<(int )strlen(b.number);i++)
        B[len++]=b.number[i];
    for(int i=0;i<(int )strlen(a.number);i++)
        B[len++]=a.number[i];
    return strcmp(A,B)<0;
}
int main()
{
    int N,i,len,j;
    scanf("%d",&N);
    for(int i=0;i<N;i++)
        scanf("%s",num[i].number);
    sort(num,num+N,cmp);
    for(j=0;j<N;j++)
    {
        len=strlen(num[j].number);
        for(i=0;i<len;i++)
            if(num[j].number[i]!='0')
                break;
        if(i<len)
        {
            while(i<len)
                printf("%c",num[j].number[i++]);
            break;
        }
    }
    if(j+1<N)
        for(i=j+1;i<N;i++)
            printf("%s",num[i].number);
    else
        printf("0");
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值