POJ-3468-A Simple Problem with Integers(线段树区间更新)

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15


思路:坑爹的64位整数啊,终于AC了。


#include <stdio.h>
#include <string.h>

__int64 sum[300000],add[300000],N,Q,ans;

void build(__int64 left,__int64 right,__int64 index)
{
    if(left==right)
    {
        scanf("%I64d",&sum[index]);
        add[index]=sum[index];
    }
    else
    {
        __int64 mid=(left+right)>>1;

        build(left,mid,index<<1);
        build(mid+1,right,index<<1|1);
        sum[index]=sum[index<<1]+sum[index<<1|1];
    }
}

void updateroot(__int64 left,__int64 right,__int64 index)
{
    sum[index]=0;
    if(left<right)
        sum[index]=sum[index<<1]+sum[index<<1|1];
    sum[index]+=add[index]*(right-left+1);
}

void update(__int64 L,__int64 R,__int64 left,__int64 right,__int64 index,__int64 v)
{
    if(L<=left && right<=R)
        add[index]+=v;
    else
    {
        __int64 mid=(left+right)>>1;

        if(L<=mid) update(L,R,left,mid,index<<1,v);
        if(R>mid) update(L,R,mid+1,right,index<<1|1,v);
    }

    updateroot(left,right,index);
}

void query(__int64 L,__int64 R,__int64 left,__int64 right,__int64 index,__int64 attach)
{
    if(L<=left && right<=R)
        ans+=sum[index]+attach*(right-left+1);
    else
    {
        __int64 mid=(left+right)>>1;

        if(L<=mid) query(L,R,left,mid,index<<1,attach+add[index]);
        if(R>mid) query(L,R,mid+1,right,index<<1|1,attach+add[index]);
    }
}

int main()
{
    __int64 i,a,b,c;
    char s[100];

    while(~scanf("%I64d%I64d",&N,&Q))
    {
        memset(sum,0,sizeof(sum));
        memset(add,0,sizeof(add));

        build(1,N,1);

        gets(s);
        for(i=0;i<Q;i++)
        {
            gets(s);
            if(s[0]=='Q')
            {
                sscanf(s,"%*s%I64d%I64d",&a,&b);
                ans=0;
                query(a,b,1,N,1,0);
                printf("%I64d\n",ans);
            }
            else
            {
                sscanf(s,"%*s%I64d%I64d%I64d",&a,&b,&c);
                update(a,b,1,N,1,c);
            }
        }
    }
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值