【PAT】1028. List Sorting (25)

题目


链接:https://www.patest.cn/contests/pat-a-practise/1028

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90




分析


题意:

1. C == 1
根据学号排序(升序)
2. C == 2
根据名字(升序)
3. C == 3
根据分数(升序)

若有相同,则根据学号升序</font>




题解(已AC)


/**
    2018.2.2
    Donald
*/
//1028. List Sorting (25)

/**
    1. C == 1
        根据学号排序(升序)
    2. C == 2
        根据名字(升序)
    3. C == 3
        根据分数(升序)

    若有相同,则根据学号升序
*/


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 100005

struct Student {
    int id;
    char name[9];
    int score;
};

int N;
int C;
Student stu[MAXN];

bool compare1(Student a, Student b) {
    return a.id < b.id;
}

bool compare2(Student a, Student b) {
    return strcmp(a.name, b.name) != 0 ? strcmp(a.name, b.name) < 0 : a.id < b.id;
}

bool compare3(Student a, Student b) {
    return a.score != b.score ? a.score < b.score : a.id < b.id;
}

int main(void) {

    while (scanf("%d %d", &N, &C) == 2) {
        for (int i = 0; i < N; ++i) {
            scanf("%d %s %d", &stu[i].id, stu[i].name, &stu[i].score);
        }

        if (C == 1) {
            sort(stu, stu + N, compare1);
        } else if (C == 2) {
            sort(stu, stu + N, compare2);
        } else if (C == 3) {
            sort(stu, stu + N, compare3);
        }
        for (int i = 0; i < N; ++i) {
            printf("%06d %s %d\n", stu[i].id, stu[i].name, stu[i].score);
        }
    }


    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值