最大生成树

 

POJ 2377


构建最小生成树一般使用Prim与Kruskal算法,但是两种算法处理的是带权无向连通图。对于图中的不带权有向连通图,只要按照定义保证生成树涵盖所有顶点又没有回路就可以,会有多个答案。

一个有 n 个结点的连通图的生成树是原图的极小连通子图,且包含原图中的所有 n 个结点,并且有保持图连通的最少的边。[1]  最小生成树可以用kruskal(克鲁斯卡尔)算法或prim(普里姆)算法求出。

Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie. 

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42

#include <iostream>

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
using namespace std;
const int N = 1005;
const int inf = 0x3f3f3f3f;
int n, m;
int G[N][N];
int dij()
{
    int dist[N], i, j, v, ans=0;
    bool vis[N];
    for(i=1; i<=n; i++)
    {
        vis[i]=0;
        dist[i]=G[i][1];
    }
    vis[1]=1;
    for(j=1; j<n; j++)
    {
        int Max=0;
        for(i=1; i<=n; i++)
        {
            if(!vis[i]&&dist[i]>Max)
            {
                Max=dist[i];
                v=i;
            }
        }
        if(Max==0)
            return -1;
        ans+=Max;
        vis[v]=1;
        for(i=1; i<=n; i++)
        {
            if(!vis[i]&&dist[i]<G[v][i])//和dijkstra的重要区别之一, if(!vis[i]&&dist[i]<G[v][i]+dist[v])  dist[i]=G[v][i]+dist[v];
                dist[i]=G[v][i];
        }
    }
    return ans;
}
int main()
{
    int i, a, b, c;
    while(~scanf("%d %d", &n, &m))
    {
        memset(G,0,sizeof(G));
        while(m--)
        {
            scanf("%d %d %d", &a, &b, &c);
            if(G[a][b]<c)//注意有重边(比如5 4 3 和5 4 2)3>2 不被更新
            G[a][b]=G[b][a]=c;
        }
        printf("%d\n",  dij());
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值