POJ 3468 线段树(区间更新)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 85553 Accepted: 26573
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

线段树的区间更新,代码量比较大,写的时候容易出错。



#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 100005 ;
struct node{
    int l,r;
    long long sum,add ;
};
node tree[3*maxn] ;
int N,q;
void build(int i,int l,int r){
    tree[i].l=l;
    tree[i].r=r;
    tree[i].add=0;
    tree[i].sum=0;
    if(l==r)return ;
    int mid = (l+r)/2 ;
    build(2*i,l,mid);
    build(2*i+1,mid+1,r);
}
void pushdown(int i,int l,int r){
    int mid = (l+r)/2 ;
    tree[2*i].add+=tree[i].add ;
    tree[2*i+1].add+=tree[i].add ;
    tree[2*i].sum+=tree[i].add*(mid-l+1) ;
    tree[2*i+1].sum+=tree[i].add*(r-mid) ;
    tree[i].add=0 ;
}
void update(int i,int l,int r,int yl,int yr,long long v){
    if(yl<=l&&r<=yr){
        tree[i].add+=v;
        tree[i].sum+=v*(r-l+1) ;
    }else{
        int mid=(l+r)/2 ;
        pushdown(i,l,r) ;
        if(yl<=mid)update(2*i,l,mid,yl,yr,v);
        if(mid<yr)update(2*i+1,mid+1,r,yl,yr,v);
        tree[i].sum=tree[2*i].sum+tree[2*i+1].sum ;
    }
}
long long query(int i,int l,int r,int ql,int qr){
    long long ret = 0 ;
    if(ql<=l&&r<=qr){
        return tree[i].sum ;
    }else{
        int mid = (l+r)/2 ;
        pushdown(i,l,r) ;
        if(ql<=mid)ret+=query(2*i,l,mid,ql,qr);
        if(mid<qr)ret+=query(2*i+1,mid+1,r,ql,qr) ;
        return ret ;
    }
}

int main(){
    while(~scanf("%d%d",&N,&q)){
        memset(tree,0,sizeof(tree));
        build(1,1,N);
        for(int i=1;i<=N;i++){
            int a ;
            scanf("%d",&a);
            update(1,1,N,i,i,a);
        }
        for(int i=0;i<q;i++){
           int a,b,c;
           char str[10] ;
           scanf("%s",str);
           if(str[0]=='C'){
                scanf("%d %d %d",&a,&b,&c);
                update(1,1,N,a,b,c);
           }else{
                scanf("%d%d",&a,&b);
                printf("%I64d\n",query(1,1,N,a,b));
           }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值