HDU 1016素数环(深度搜索)

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38934    Accepted Submission(s): 17188


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2


打素数表,深度搜索,由于是个环,最后一个数要拿出来单独处理。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 100 ;
int n ;
bool flag[maxn] ;
int arry[maxn] ;
bool isprime[maxn];
void init(){  ///打素数表
    memset(isprime,true,sizeof(isprime)) ;
    isprime[0]=false;
    isprime[1]=false;
    for(int i=2;i<maxn;i++){
        for(int j=2;j<maxn;j++){
            isprime[i*j]=false ;
        }
    }
    return ;
}
void dfs(int x){  ///递归层数
    if(x==n){
        for(int i=1;i<=n;i++){
            if(!flag[i]&&isprime[arry[1]+i]&&isprime[arry[x-1]+i]){///这里两个比较,容易漏掉
                arry[n]=i ;
                for(int j=1;j<n;j++){
                    printf("%d ",arry[j]);
                }
                printf("%d\n",arry[n]);
                return ;
            }
        }
        return ;
    }
    for(int i=1;i<=n;i++){
        if(!flag[i]&&isprime[arry[x-1]+i]){///最常用的递归手法。
            arry[x]=i;
            flag[i]=true ;
            dfs(x+1);
            flag[i]=false ;
        }
    }
}
int main(){
    init();
    int cas = 1 ;
    while(~scanf("%d",&n)){
        printf("Case %d:\n",cas++);
        memset(flag,false,sizeof(flag));
        arry[1]=1 ;
        flag[1]=true ;
        dfs(2);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值