HDU 3746 Cyclic Nacklace 数据结构+kmp周期类问题

Cyclic Nacklace

Time Limit:
1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
 

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 

Sample Input

    
    
3 aaa abca abcde
 

Sample Output

  
  
0 2 5 解题思路: 这题是kmp问题,涉及到的也是失配函数/next数组的应用 对于这个问题,如何才能添加最少的珍珠让这个周期>=2呢? 首先我们主要是判断最后一个字符,对于最后一个字符n-f[n]就是n前面有多少字符和前缀匹配 那么这个匹配的长度的字符串如果是一个周期串的话,那么它就一定是一个循环节。 这样就可以得到输出0的条件if(n%(n-f[n])==0&&f[n]!=0)printf("0\n");f[n]==0表示没有循环,要排除 对于要添加的串的数目我们应该如何获取呢? 那么分析,如果我假设这个串不完全,我要添加最少的数量构成周期串的话,我就应该是让添加的字符他的next增大 达到能被n整出的效果,那么公式(n-f[n])-n%(n-f[n])就是结果。
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxn = 2000005 ;
char str[maxn] ;
int f[maxn] ;
void getfail(){
    f[0] = 0 ;
    f[1] = 0 ;
    int n = strlen(str) ;
    for(int i=1;i<n;i++){
        int j = f[i] ;
        while(j&&str[i]!=str[j])j = f[j] ;
        f[i+1] = (str[i]==str[j]?j+1:0) ;
    }
    return ;
}
int main(){
    int T ;
    scanf("%d",&T);
    while(T--){
        scanf("%s",str);
        int n = strlen(str) ;
        memset(f,0,sizeof(f));
        getfail() ;

//        for(int i=0;i<n;i++){
//            printf("%d ",f[i]);
//        }printf("\n");

        if(n%(n-f[n])==0&&f[n]!=0)printf("0\n");
        else printf("%d\n",(n-f[n])-n%(n-f[n]));
    }
    return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值