HDU 1671 phone list 数据结构+Trie树(字典树、前缀树)

phone list

Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

解题思路:

字典树的问题,这题存的可以不是字符串,但是一样可以作为字符串来做

因为只要判断一个号码是否出现在另外一个号码中作为前缀,两种方法:

1,先对模式串处理,按照长短排序,这样短的先插入,判断重复的条件就是新插入的字符串走到了别人的单词节点

2,不处理模式串,直接插入,如果新插入的字符串走到了别人的单词节点就结束,或者插入完成,发现是在别人的单词路径上。也要结束

两种方法都能做,一旦发现有不合格的以后的输入也都不需要判断了。

其实只要掌握了字典树,这些问题还是非常灵活的。


#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int n ;
bool flag;
const int maxnode = 10005*15 ;
const int sigma_size = 26 ;

struct Trie{
    int ch[maxnode][sigma_size] ;
    int val[maxnode] ;
    int sz;
    void clear(){
        sz = 1 ;
        memset(val,0,sizeof(val));
        memset(ch[0],0,sizeof(ch[0]));
    }
    int idx(char x){return x-'0';}

    bool check(int u){
        for(int i=0;i<26;i++){
            if(ch[u][i]!=0)return true ;
        }
        return false ;
    }

    void insert(const char *s,int v){
        int u = 0 ;
        int n = strlen(s) ;
        for(int i=0;i<n;i++){
            int c = idx(s[i]) ;
            if(!ch[u][c]){
                memset(ch[sz],0,sizeof(ch[sz])) ;
                val[sz] = 0 ;
                ch[u][c] = sz++ ;
            }
            u = ch[u][c];
            if(val[u]!=0)flag = false ;

        }
        val[u] = v;
        if(check(u))flag = false ;
    }

};

Trie trie;

int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        flag = true ;
        scanf("%d",&n);
        char str[100] ;
        trie.clear();
        for(int i=1;i<=n;i++){
            scanf("%s",str);
            if(flag)trie.insert(str,i) ;
            //else printf("i = %d\n",i);
        }
        if(flag)printf("YES\n");
        else printf("NO\n");
    }
    return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值