POJ 2406 Power Strings 数据结构+KMP

 Power Strings
Time Limit:3000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

解题思路:
一看就知道考的是kmp的失配函数/next数组的含义
看最后一个字符的f[i] 如果n%(n-f[n])!=0那就是不循环的
否则循环节就是n/(n-f[n])
面对这种题,只要自己对失配函数和next理解到一定程度,基本不用太多思考

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int maxn = 1000005 ;
char str[maxn] ;
int f[maxn] ;
void getfail(){
    f[0] = 0 ;
    f[1] = 0 ;
    int n = strlen(str);
    for(int i=1;i<n;i++){
        int j = f[i] ;
        while(j&&str[i]!=str[j])j = f[j] ;
        f[i+1] = (str[i]==str[j]?j+1:0) ;
    }
    return ;
}
int main(){
    while(~scanf("%s",str)){
        if(str[0]=='.')break ;
        getfail();

//        for(int i=0;i<=strlen(str);i++){
//            printf("%d ",f[i]);
//        }printf("\n");

        int n = strlen(str) ;
        int t = n-f[n];
        if(n%t==0){
            printf("%d\n",n/t);
        }else{
            printf("1\n");
        }
    }
    return 0;

}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值