POJ 2828 Buy Tickets线段树+点更新+小技巧

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 18247 Accepted: 9057

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ iN). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.




解题思路:
做了这一题才感觉这题真好,让我知道了线段树的一种应用
其实线段树就是一种二叉树,他又logn的时间复杂度,所以我们要用它
但是如何来用是一个只有通过慢慢的积累才能灵活掌握。

对于这一题,首先如何想到是线段树的题目?
1,其他的方法无法解决,有人插队,难道你要去模拟这个过程?链表复杂度太高,每一次的插入都是O(n)的时间
又有n个人来插队,所以我们能想到的就是把复杂度降到nlogn,那么快速的执行这种操作就是线段树了。
2,后面来的人的位置是固定的,前面来的人的位置是不固定的,这题可以倒着输入数据,先从后面的人入手,
那么前面的人怎么办?策略是:如果我插入位置有人了,我就找后面第一个空位置。
3,怎么做?观察输入,题目保证每次插入人的位置之前一定是有人的(之前没人不能插队比如4位置空着我去插队到5位置,不可能)
那么这就意味着,我插入一个人位置是p,他前面一定是坐满人的,对于线段树那也就是说插的时候,我要左子树提供足够数目的
位置p,如果不行的话那我就要去右子树找后面的位置了,那我希望右子数能够给我提供p-左子数空位数目。
4,好好品味吧。

///区间求和的题目
#include <cstdio>
#include <cstring>
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
///rt<<1|1 ;相当于rt*2+1
const int maxn = 200005;
int sum[maxn<<2];
int ans[maxn<<2];
int ss;
void PushUP(int rt) {///更新父节点的值
	sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}
void build(int l,int r,int rt) {///建树范围(1,n),根节点为1。
	if (l == r) {
		sum[rt] = 1 ;
		return ;
	}
	int m = (l + r) >> 1;
	build(lson);
	build(rson);
	PushUP(rt);
}
void update(int p,int add,int l,int r,int rt) {///第p个节点增加add,范围(1,n),根节点为1。
	if (l == r) {
		sum[rt] += add;
        ans[l] = ss ;
		return ;
	}
	int m = (l + r) >> 1;
	if (p<=sum[rt<<1]) update(p , add , lson);///这里是最重要的
	else update(p-sum[rt<<1] , add, rson);
	PushUP(rt);
}
int arry[maxn][2] ;
int main() {
    int n ;
	while(~scanf("%d",&n)){
        memset(ans,0,sizeof(ans)) ;
	    build(1,n,1) ;
        for(int i=0;i<n;i++){
            scanf("%d%d",&arry[i][0],&arry[i][1]);
        }
        for(int i=n-1;i>=0;i--){
            ss = arry[i][1] ;
            update(arry[i][0]+1,-1,1,n,1) ;
        }
        for(int i=1;i<n;i++){
            printf("%d ",ans[i]);
        }printf("%d\n",ans[n]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值