HDU 2602 Bone Collector 收集骨头+最基本的01背包

HDU 2602 Bone Collector

Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Appoint description:

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14


解题思路:刚看过01背包,感觉还可以
题意:一个人收集骨头,下面有5个骨头他背了一个容量为10的包
第一行为骨头的价值
第二行为骨头的体积
要你求包里面能装下的最多的骨头的价值
就是一个状态转换方程要把握好
dp[j] = max(dp[j],dp[j-volume[i]]+value[i]) ;
其实他是由dp[i][j] = max(dp[i-1][j],dp[i-1][j-volume[i]]+value[i]);
转换而来的,但是考虑到之前的值没有用到,所以可以变成一维数组,通过刷新来实现dp


///01背包基础
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1005 ;
int value[maxn] ;
int volume[maxn] ;
int dp[maxn] ;
int N,V ;///物品数目和背包容量
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&N,&V);
        int n=N ;
        for(int i=1;i<=n;i++)scanf("%d",&value[i]);
        for(int i=1;i<=n;i++)scanf("%d",&volume[i]);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++){///第i个物品放入容量为v的背包获得的最大价值
            for(int j=V;j>=volume[i];j--){
                dp[j] = max(dp[j],dp[j-volume[i]]+value[i]) ;
            }
        }
        printf("%d\n",dp[V]) ;
    }
    return 0;
}
/*
1
5 10
1 2 3 4 5
5 4 3 2 1

样例数
5件物品背包容量为10
第一行为价值
第二行为体积
*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值