HDU 3466 Dividing coins 01背包变形+技巧

HDU 3466 Dividing coins
Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u
Appoint description:

Description

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

Input

There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

Output

For each test case, output one integer, indicating maximum value iSea could get.

Sample Input

2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3

Sample Output

5
11

解题思路:
这题其实不简单,关键是不好想,不过做多了就好想了
1,首先是01背包,但是要求买的时候要有q的钱才能买
2,那么那我买的时候就得有max(p,q);的钱才能买
3,然后状态转移方程就是dp[j] = max(dp[j],dp[j-arry[i].p]+arry[i].v);
4,然后总觉得还缺些什么,这样写不是最优的
5,还要根据q-p排序从小到大,这样才是最优的,要让q比p多的最小的先判断买或不买
6,主要是考虑状态转移方程的无后效性吧

#include<bits/stdc++.h>
using namespace std;
const int maxn = 505 ;
struct node{
    int p,q,v;
};
node arry[maxn] ;
int dp[5005] ;
bool cmp(node x,node y){
    return (x.q-x.p)<(y.q-y.p) ;
}
int main(){
    int n,m;
    while(~scanf("%d%d",&n,&m)){
        for(int i=1;i<=n;i++){
            scanf("%d%d%d",&arry[i].p,&arry[i].q,&arry[i].v);
        }
        sort(arry+1,arry+n+1,cmp) ;
        memset(dp,0,sizeof(dp)) ;
        for(int i=1;i<=n;i++){///按照q-p排序
            for(int j=m;j>=max(arry[i].q,arry[i].p);j--){
                dp[j] = max(dp[j],dp[j-arry[i].p]+arry[i].v);
            }
//            for(int k=1;k<=m;k++){
//                printf("%d ",dp[k]);
//            }printf("\n");
        }
        int ans = dp[m] ;
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值