POJ 2955 Brackets+区间dp

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6621 Accepted: 3557

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im n, ai1ai2aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

题意:给你一个括号序列求它的最长子序列(可以非连续)是合法括号序列的最大长度
思路:
1,区间dp的题目,那么就是先枚举区间
2,分析:
if(match(str[i],str[j]))dp[i][j]=dp[i+1][j-1]+2;///如果区间i,j匹配了,s是个子序列那么它属于(s)的情况
else dp[i][j]=dp[i+1][j] ;///否则的话,等于前面算过的区间的
for(int k=i;k<=j;k++)dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);///然后再去找其他的情况,比如()(),或()[]的情况

3,区间dp的大致情形都是这样。





#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxn = 1003 ;
char str[maxn] ;
int dp[maxn][maxn] ;
bool match(char a,char b){
    if(a=='('&&b==')')return true ;
    else if(a=='['&&b==']')return true ;
    else return false ;
}
int main(){
    while(~scanf("%s",str)){
        if(strcmp(str,"end")==0)break;
        int n=strlen(str) ;
        memset(dp,0,sizeof(dp));
        for(int i=n-2;i>=0;i--){
            for(int j=i+1;j<n;j++){
                dp[i][j]=0 ;
                if(match(str[i],str[j]))dp[i][j]=dp[i+1][j-1]+2;
                else dp[i][j]=dp[i+1][j] ;
                for(int k=i;k<=j;k++){
                    dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
                }
            }
        }
        printf("%d\n",dp[0][n-1]);
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值