POJ 2955 Brackets(区间DP)

Problem Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < imn, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

 

 Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

 

 Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

 

 Sample Input 

((()))

()()()

([]])

)[)(

([][][)

end

 

Sample Output 

6

6

4

0

6

 

题意:

给出一个字符串,问该字符串中括号的最大的匹配是多少()为一对括号的匹配,[]为一对括号的匹配。

思路:

区间DP
dp[i][j]表示i-j这个区间中括号的最大匹配数,可知对于每一个区间来说,初值为如果s[i] s[j]恰好可以匹配,那么dp[i][j]=dp[i+1][j-1]+2,如果不匹配,那么dp[i][j]=dp[i+1][j-1];
然后遍历区间断点K,求最大值。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[110];
int dp[110][110];
int main()
{
    while(~scanf("%s",s))
    {
        if(s[0]=='e')
            break;
        memset(dp,0,sizeof(dp));
        int n=strlen(s);
        for(int len=1;len<=n;len++)
        {
            for(int l=0;l+len<n;l++)
            {
                int r=l+len;
                if((s[l]=='('&&s[r]==')')||(s[l]=='['&&s[r]==']'))
                    dp[l][r]=dp[l+1][r-1]+2;
                for(int k=l;k<r;k++)
                    dp[l][r]=max(dp[l][r],dp[l][k]+dp[k+1][r]);
            }
        }
        printf("%d\n",dp[0][n-1]);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值