2025 Problem G 比较字符串

389 篇文章 1 订阅
144 篇文章 2 订阅

问题 G: 比较字符串
时间限制: 1 Sec 内存限制: 32 MB
献花: 36 解决: 30
[献花][花圈][TK题库]
题目描述
输入两个字符串,比较两字符串的长度大小关系。
输入
输入第一行表示测试用例的个数m,接下来m行每行两个字符串A和B,字符串长度不超过50。
输出
输出m行。若两字符串长度相等则输出A is equal long to B;若A比B长,则输出A is longer than B;否则输出A is shorter than B。
样例输入
2
abc xy
bbb ccc
样例输出
abc is longer than xy
bbb is equal long to ccc

#include <iostream>
#include <fstream>
#include <cstring>
using namespace std;

const int MaxN = 51;
int main()
{
#ifdef _DEBUG
    ifstream cin("data.txt");
#endif // _DEBUG

    int n,res;
    char a[MaxN], b[MaxN];
    cin >> n;
    while (n--)
    {
        cin >> a >> b;
        res = strlen(a) - strlen(b);
        if (res > 0)
            cout << a << " is longer than " << b << endl;
        else if(res)
            cout << a << " is shorter than " << b << endl;
        else
            cout << a << " is equal long to " << b << endl;
    }
#ifdef _DEBUG
    cin.close();
    system("pause");
#endif // _DEBUG

    return 0;
}

/**************************************************************
    Problem: 2025
    User: Sharwen
    Language: C++
    Result: 升仙
    Time:2 ms
    Memory:1704 kb
****************************************************************/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值