1010. Radix (25)

389 篇文章 1 订阅
140 篇文章 0 订阅

1010. Radix (25)
时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is “yes”, if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.
Input Specification:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number “radix” is the radix of N1 if “tag” is 1, or of N2 if “tag” is 2.
Output Specification:
For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print “Impossible”. If the solution is not unique, output the smallest possible radix.
Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible

注意点:

  • 进制范围要进行限制,为最大位+1 至 题目给出进制对应的数据的十进制值加1
  • 可能溢出,所以要特殊处理
#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <cstring>
#include <fstream>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
using namespace std;

const int MaxN = 100010;

int Map[130];

void init()
{
    for (int i = 0; i < 10; ++i)
        Map[i + '0'] = i;
    for (char c = 'a'; c <= 'z'; ++c)
        Map[c] = c - 'a' + 10;
}



long long StringToLongLong(string a,long long radix)
{
    if (radix == 0) return 0;
    long long res = 0;
    long long POW = 1;
    int size = a.size();
    for (int i = size - 1; i >= 0; --i, POW *= radix)
        res += Map[a[i]] * POW;
    if (res < 0)
        return -1;
    return res;
}

int FindLow(string a)
{
    int size = a.size();
    int max = -1;
    for (int i = 0; i < size; ++i)
    {
        if (Map[a[i]] > max)
            max = Map[a[i]];
    }
    return max + 1;
}


bool CanbeDone(string n,long long & radix,long long value,long long left,long long right)
{
    long long val, mid;
    while (left <= right)
    {
        mid = left + (right - left) / 2;
        val = StringToLongLong(n, mid);
        if (value < val || val == -1)
            right = mid - 1;
        else if (value > val)
            left = mid + 1;
        else
        {
            radix = mid;
            return true;
        }

    }
    return false;
}


int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
    //fstream cin("data.txt");
#endif // _DEBUG

    string N1, N2;
    int tag;
    long long num1,maxradix, radix;

    init();

    cin >> N1 >> N2 >> tag >> radix;
    if (tag == 2)
        swap(N1, N2);

    num1 = StringToLongLong(N1, radix);
    maxradix = num1 + 1;

    long long low = FindLow(N2);
    if (CanbeDone(N2, radix, num1, low, max(low,maxradix)))
        printf("%lld", radix);
    else
        printf("Impossible");


#ifdef _DEBUG
    //cin.close();
#ifndef _CODEBLOCKS
    std::system("pause");
#endif // !_CODEBLOCKS
#endif // _DEBUG

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值