PAT (Advanced Level) 1010. Radix (25) 进制匹配 二分法

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.

Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible
使用long long保证不溢出,待求进制的下界是待求字符串最大数字(转为十进制)加1,上界是已知进制字符串转为十进制的值加1。由于范围很大,使用二分法,stringToLongLong函数在进制较大时会因溢出返回-1。
/*2015.7.19cyq*/
#include <iostream>
#include <string>
#include <vector>
using namespace std;

long long stringToLongLong(const string &s,long long radix){
	int len=s.size();
	long long result=0;
	int tmp;
	for(int i=0;i<len;i++){
		if(s[i]>='0'&&s[i]<='9')
			tmp=s[i]-'0';
		else if(s[i]>='a'&&s[i]<='z')
			tmp=s[i]-'a'+10;
		else
			return -1;
		result=result*radix+tmp;
		if(result<0)//溢出
			return -1;
	}
	return result;
}

int main(){
	string n1,n2;
	int tag;
	long long radix;
	cin>>n1>>n2>>tag>>radix;
	int result;
	if(tag==2)
		swap(n1,n2);
	long long target=stringToLongLong(n1,radix);
	long long minRadix=2;
	for(int i=0;i<n2.size();++i){
		if(n2[i]>='0'&&n2[i]<='9'){
			if(n2[i]-'0'>=minRadix)
				minRadix=n2[i]-'0'+1;
		}else if(n2[i]>='a'&&n2[i]<='z')
			if(n2[i]-'a'+10>=minRadix)
				minRadix=n2[i]-'a'+10+1;
	}
	long long maxRadix=target+1;
	long long mid,tmp;
	while(minRadix<=maxRadix){
		mid=minRadix+(maxRadix-minRadix)/2;
		tmp=stringToLongLong(n2,mid);
		if(tmp==-1||tmp>target)//进制太大
			maxRadix=mid-1;
		else if(tmp<target)//进制太小
			minRadix=mid+1;
		else{//tmp==target
			cout<<mid;
			return 0;
		}
	}

	cout<<"Impossible";
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值