1029. Median (25)

389 篇文章 1 订阅
140 篇文章 0 订阅

1029. Median (25)
时间限制 1000 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.
Given two increasing sequences of integers, you are asked to find their median.
Input
Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.
Output
For each test case you should output the median of the two given sequences in a line.
Sample Input
4 11 12 13 14
5 9 10 15 16 17
Sample Output
13

注意点:

  • 数组的元素定义为long long,或者long int,输入的时候注意控制符
  • 也可以两个数组合并后取中间的元素,可能会超时,我没试,毕竟没合并运行时间最高已经315ms了
#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <cstring>
#include <fstream>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
using namespace std;

const int MaxN = 1000010;
long long int seq1[MaxN], seq2[MaxN];

long long FindMedian(long long a[], long int N, long long b[],long int M)
{
    long int Mid, i = 0, j = 0, count = 0;
    if ((N + M) % 2 == 0)Mid = ((long long)N + M) / 2 - 1;
    else Mid = ((long long)N + M) / 2;

    while (i < N && j < M)
    {
        if (a[i] < b[j])
        {
            if (count == Mid)
                return a[i];
            ++i;
        }
        else
        {
            if (count == Mid)
            {
                return b[j];
            }
            ++j;
        }
        ++count;
    }
    while (i < N)
    {
        if (count == Mid)
            return a[i];
        ++i;
        ++count;
    }

    while (j < M)
    {
        if (count == Mid)
            return b[j];
        ++j;
        ++count;
    }
    return -1;
}

int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
    //fstream cin("data.txt");
#endif // _DEBUG

    long int N, M;
    scanf("%d", &N);

    for (long int i = 0; i < N; ++i)
        scanf("%lld", &seq1[i]);

    scanf("%d", &M);
    for (long int i = 0; i < M; ++i)
        scanf("%lld", &seq2[i]);

    printf("%lld", FindMedian(seq1, N, seq2, M));



#ifdef _DEBUG
    //cin.close();
#ifndef _CODEBLOCKS
    std::system("pause");
#endif // !_CODEBLOCKS
#endif // _DEBUG

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值