PAT A1029. Median (25)

原文链接: PAT A1029. Median (25)

上一篇: PAT A1089. Insert or Merge (25)

下一篇: PAT A1093. Count PAT's (25)

1029. Median (25)

https://www.patest.cn/contests/pat-a-practise/1029

时间限制

1000 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int .

Output

For each test case you should output the median of the two given sequences in a line.

Sample Input

4 11 12 13 14
5 9 10 15 16 17

Sample Output

13

思路:

两个有序序列的合并问题,新序列的长度已知,则中位数所在位置是知道的

为了使代码更加简练,不妨令两个序列的最后都添加一个很大的数INF,这样在扫描过程中,就可以在其中一个序列已经扫描完但cnt还没有到中位数的情况下解决越界问题

最后输出较小值是因为当cnt达到中位数的位置时在while循环中还没有对a[i],b[j]的大小进行判断

#include <vector>
#include <iostream>
#include <cstdio>
using namespace std;
int main() {
    int m, n, p = 0, q = 0;
    scanf("%d", &m);
    vector<long int> v1(m);
    for(int i = 0; i < m; i++)
        scanf("%ld", &v1[i]);
    scanf("%d", &n);
    vector<long int> v2(n);
    for(int i = 0; i < n; i++)
        scanf("%ld", &v2[i]);
    int cnt = ((m + n) - 1) / 2;
    while(cnt) {
        while(p < m && q < n && v1[p] < v2[q] && cnt) {
            p++;
            cnt--;
        }
        while(p < m && q < n && v1[p] >= v2[q] && cnt) {
            q++;
            cnt--;
        }
        while(p < m && q >= n && cnt) {
            p++;
            cnt--;
        }
        while(p >= m && q < n && cnt) {
            q++;
            cnt--;
        }
    }
    long int ans;
    if(p < m && q < n)
        ans = v1[p] < v2[q] ? v1[p] : v2[q];
    else
        ans = p < m ? v1[p] : v2[q];
    printf("%ld", ans);
    return 0;
}

#include <iostream>
#include <cstdio>
using namespace std;
const int MAX = 1000010;
int a[MAX], b[MAX];

int main(int argc, char *argv[]) {
	int n, m;
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
		scanf("%d", a + i);
	scanf("%d", &m);
	for (int i = 0; i < m; i++)
		scanf("%d", b + i);

	int mid = (n + m - 1) / 2;	//中位数所在位置
	int cnt = 0, i = 0, j = 0;		//已经排好序的数的个数,i,j分别指向a,b 

	int INF = 1<<30;
	a[n]=b[m]=INF;
	while(cnt<mid){
		if(a[i]<b[j])
			i++;
		else
			j++;
		cnt++;
	}
	
	printf("%d\n", min(a[i], b[j]));
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值