1059. Prime Factors (25)

389 篇文章 1 订阅
140 篇文章 0 订阅

1059. Prime Factors (25)
时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 HE, Qinming

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 *…*pm^km.
Input Specification:
Each input file contains one test case which gives a positive integer N in the range of long int.
Output Specification:
Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi’s are prime factors of N in increasing order, and the exponent ki is the number of pi – hence when there is only one pi, ki is 1 and must NOT be printed out.
Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291

注意点:

  • 对输入为1要特殊判断和处理
#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <cstring>
#include <fstream>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
using namespace std;

const int MaxN = 1000010;
int Prime[MaxN] , PN = 0 ,FN = 0;
bool Nop[MaxN] = { 0 };

struct Factor
{
    int num;
    int c;
}Fact[1000] = { 0 };

void GetPrimeTable(int n)
{
    for (int i = 2; i < MaxN; ++i)
    {
        if (!Nop[i])
        {
            Prime[PN++] = i;
            if (PN >= n)break;
            for (int j = 2 * i; j < MaxN; j += i)//倍数关系,因此直接到2 * i即可
            {
                if (j % i == 0)
                {
                    Nop[j] = true;
                }
            }
        }
    }
}

int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif // _DEBUG


    long int N,T;
    int i;
    double sqr;
    cin >> N;
    T = N;
    sqr = sqrt(N);

    GetPrimeTable(10000);

    for (i = 0; i < PN && Prime[i] < sqr && N!=1; ++i)
    {
        if (N % Prime[i] == 0)
        {
            Fact[FN].c = 1;
            Fact[FN].num = Prime[i];
            N /= Prime[i];
            while (N % Prime[i] == 0)
            {
                N /= Prime[i];
                Fact[FN].c += 1;
            }
            ++FN;
        }
    }
    if (N != 1)
    {
        Fact[FN].num = N;
        Fact[FN++].c = 1;
    }

    if (FN > 0)
    {
        printf("%ld=%d", T, Fact[0].num);
        if (Fact[0].c > 1)
        {
            printf("^");
            printf("%d", Fact[0].c);
        }
    }
    for (int i = 1; i < FN; ++i)
    {
        printf("*%d", Fact[i].num);
        if (Fact[i].c > 1)
        {
            printf("^");
            printf("%d", Fact[i].c);
        }
    }
    if (T == 1)
        printf("1=1");

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值