1107. Social Clusters (30)

389 篇文章 1 订阅
140 篇文章 0 订阅

1107. Social Clusters (30)
时间限制 1000 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A “social cluster” is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.
Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:
Ki: hi[1] hi[2] … hi[Ki]
where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].
Output Specification:
For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>

using namespace std;
const int MaxN = 1010;

int father[MaxN] = { 0 }, hobby[MaxN] = { 0 }, clusN[MaxN] = {0};
bool isRoot[MaxN] = { false };


void Init(int n)
{
    for (int i = 0; i < n; ++i)
    {
        father[i] = i;
        isRoot[i] = false;
    }
}


int findFather(int id)
{
    int root = id;
    while (root != father[root])
        root = father[root];

    while (id != father[id])
    {
        int tmp = father[id];
        father[id] = root;
        id = tmp;
    }

    return root;
}


void Union(int a, int b)
{
    int fa = findFather(a);
    int fb = findFather(b);

    if (fa != fb)
    {
        father[fb] = fa;
        clusN[fa] += clusN[fb];
    }
}


bool cmp(int a, int b)
{
    return a > b;
}

int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif // _DEBUG

    //std::ios::sync_with_stdio(false);

    int N,hbs,hid;

    scanf("%d", &N);
    Init(N);

    for (int i = 1; i <= N; ++i)
    {
        scanf("%d:", &hbs);
        for (int k = 0; k < hbs; ++k)
        {
            scanf("%d", &hid);
            if (hobby[hid] == 0)
            {
                hobby[hid] = i;
            }
            Union(i, hobby[hid]);
        }
    }


    for (int i = 1; i <= N; ++i)
    {
        isRoot[findFather(i)] = true;
    }

    int RootN = 0;
    for (int i = 0; i < N; ++i)
    {
        RootN += isRoot[i];
        ++clusN[findFather(i)];
    }


    sort(clusN, clusN + N + 1, cmp);

    printf("%d\n", RootN);
    for (int i = 0; i < RootN; ++i)
    {
        printf("%d", clusN[i]);
        if (i != RootN - 1)
            printf(" ");
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值