solution Of 1107. Social Clusters (30)

48 篇文章 0 订阅

1107. Social Clusters (30)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A “social cluster” is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki: hi[1] hi[2] … hi[Ki]

where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1


结题思路 :
题意要求我们将输出注册用户的用户群。
要求1:利用并查集来处理,将用户兴趣集存在交集的划归到一类;
要求2:并查集部分的需要做距离压缩。

程序步骤:
第一步、将用户的第一个兴趣作为用户最后的兴趣类别;
第二步、将每个用户的兴趣集做一遍并查集;
第三步、对之前每个用户暂存的兴趣类别放入并查集中查询,返回最后的类别;
第四步、根据题目要求的数据输出格式做出一定的调整。

具体程序(AC)如下:

#include <iostream>
#include <vector>
#include <string>
#include <cstring>
#include <algorithm>
#define maxS 1005
using namespace std;
vector<int> classify;
int parent[maxS];
int findRoot(int a)
{
    if(parent[a]==0)
        return a;
    else//压缩距离的处理
        return parent[a]=findRoot(parent[a]);
}
void unionJoin(int a,int b)
{
    int ra=findRoot(a);
    int rb=findRoot(b);
    if(ra!=rb)
        parent[ra]=rb;
}
int main()
{
    int num;
    cin>>num;
    memset(parent,0,sizeof(parent));
    classify.resize(num);
    int hobbySize,hobbyStart,hobby;
    for(int i=0;i<num;++i)//对兴趣进行分类,对用户进行简单分类
    {
        cin>>hobbySize;
        getchar();
        cin>>hobbyStart;
        classify[i]=hobbyStart;//粗归类
        for(int j=1;j<hobbySize;++j)
        {
            cin>>hobby;
            unionJoin(hobbyStart,hobby);
        }
    }
    for(int i=0;i<num;++i)//对用户进行正确分类
        classify[i]=findRoot(classify[i]);//细归类
    //其实到这里大体上的计算已经完成了,以下部分是对输出格式的要求做出的修正。  
    int visited[maxS];
    memset(visited,0,sizeof(visited));
    for(int i=0;i<num;++i)
        ++visited[classify[i]];
    vector<int> result;
    result.clear();
    for(int i=0;i<maxS;++i)
        if(visited[i]>0)
            result.push_back(visited[i]);
    sort(result.begin(),result.end());
    reverse(result.begin(),result.end());
    cout<<result.size()<<endl;
    if(result.size()>0)
        cout<<result[0];
    for(int i=1;i<result.size();++i)
        cout<<" "<<result[i];
    cout<<endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值