1065. 单身狗(25)

389 篇文章 1 订阅
72 篇文章 0 订阅

1065. 单身狗(25)
时间限制 300 ms 内存限制 65536 kB 代码长度限制 8000 B
判题程序 Standard 作者 CHEN, Yue

“单身狗”是中文对于单身人士的一种爱称。本题请你从上万人的大型派对中找出落单的客人,以便给予特殊关爱。
输入格式:
输入第一行给出一个正整数N(<=50000),是已知夫妻/伴侣的对数;随后N行,每行给出一对夫妻/伴侣——为方便起见,每人对应一个ID号,为5位数字(从00000到99999),ID间以空格分隔;之后给出一个正整数M(<=10000),为参加派对的总人数;随后一行给出这M位客人的ID,以空格分隔。题目保证无人重婚或脚踩两条船。
输出格式:
首先第一行输出落单客人的总人数;随后第二行按ID递增顺序列出落单的客人。ID间用1个空格分隔,行的首尾不得有多余空格。
输入样例:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
输出样例:
5
10000 23333 44444 55555 88888

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <string>
#include <cstring>
#include <iomanip>
#include <vector>
#include <map>
#include <set>

using namespace std;
map<string, string>Couple1,Couple2;
set<string> partMember;
vector<string> singleDog;

int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif // _DEBUG
    std::ios::sync_with_stdio(false);

    int N;
    cin >> N;
    for (int i = 0; i < N; ++i)
    {
        string n1, n2;
        cin >> n1 >> n2;
        Couple1[n1] = n2;
        Couple1[n2] = n1;
    }

    cin >> N;
    for (int i = 0; i < N; ++i)
    {
        string name;
        cin >> name;
        partMember.insert(name);
    }

    for (auto it = partMember.begin();it != partMember.end();++it)
    {
        string coup;
        auto couple1 = Couple1.find(*it);
        auto couple2 = Couple2.find(*it);
        if (couple1 == Couple1.end() && couple2 == Couple2.end())singleDog.push_back(*it);
        else
        {
            auto p = (couple1 == Couple1.end()) ? couple2 : couple1;
            auto CisInPart = partMember.find(p->second);
            if (CisInPart != partMember.end())partMember.erase(CisInPart);
            else singleDog.push_back(*it);
        }
    }

    cout << singleDog.size() << endl;
    for (int i = 0; i < singleDog.size(); ++i)
    {
        cout << singleDog[i];
        if (i != singleDog.size() - 1)cout << " ";
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值