1116. Come on! Let’s C (20)
时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue
“Let’s C” is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:
0. The Champion will receive a “Mystery Award” (such as a BIG collection of students’ research papers…).
1. Those who ranked as a prime number will receive the best award – the Minions (小黄人)!
2. Everyone else will receive chocolates.
Given the final ranklist and a sequence of contestant ID’s, you are supposed to tell the corresponding awards.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=10000), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant’s ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID’s.
Output Specification:
For each query, print in a line “ID: award” where the award is “Mystery Award”, or “Minion”, or “Chocolate”. If the ID is not in the ranklist, print “Are you kidding?” instead. If the ID has been checked before, print “ID: Checked”.
Sample Input:
6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222
Sample Output:
8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?
#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <cstring>
#include <iomanip>
#include <vector>
#include <string>
#include <cfloat>
#include <queue>
#include <map>
using namespace std;
map<string, int>Rank;
const int MaxN = 10010;
enum TYPE {PRIME,FRIST,CHCO,CHEC,NONE};
bool isChecked[MaxN];
bool isPrime(int n)
{
if (n <= 1) return false;
if (n == 2) return true;
int qrt = sqrt(n);
for (int i = 2; i <= qrt; ++i)
{
if (n % i == 0)return false;
}
return true;
}
TYPE Judge(string id)
{
if (Rank.count(id))
{
int rank = Rank[id];
if (isChecked[rank] == false)
{
isChecked[rank] = true;
if (rank == 1)return FRIST;
if (isPrime(rank))return PRIME;
return CHCO;
}
return CHEC;
}
return NONE;
}
int main()
{
#ifdef _DEBUG
freopen("data.txt", "r+", stdin);
#endif // _DEBUG
std::ios::sync_with_stdio(false);
int n;
string str;
cin >> n;
for(int i=1;i<=n;++i)
{
cin >> str;
Rank[str] = i;
}
cin >> n;
for (int i = 0; i < n; ++i)
{
cin >> str;
TYPE type = Judge(str);
switch (type)
{
case FRIST:
cout << str << ": Mystery Award\n";
break;
case PRIME:
cout << str << ": Minion\n";
break;
case CHCO:
cout << str << ": Chocolate\n";
break;
case NONE:
cout << str << ": Are you kidding?\n";
break;
case CHEC:
cout << str << ": Checked\n";
break;
default:
break;
}
}
return 0;
}