1118. Birds in Forest (25)

389 篇文章 1 订阅
140 篇文章 0 订阅

1118. Birds in Forest (25)
时间限制 150 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (<= 104) which is the number of pictures. Then N lines follow, each describes a picture in the format:
K B1 B2 … BK
where K is the number of birds in this picture, and Bi’s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.
After the pictures there is a positive number Q (<= 104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.
Output Specification:
For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line “Yes” if the two birds belong to the same tree, or “No” if not.
Sample Input:
4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7
Sample Output:
2 10
Yes
No

对于并查集,需要进行路径压缩,否则有一个测试点通不过,超时

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>

using namespace std;
const int MaxN = 10010;
bool isRoot[MaxN] = { false };
bool BirdCounted[MaxN] = { false };
int RootN = 0, BirdN = 0;
int RootRecord[MaxN];

int findRoot(int a) {
    int tmp = a;
    while (a != RootRecord[a]) a = RootRecord[a];

    while (tmp != RootRecord[tmp]) {
        int r = RootRecord[tmp];
        RootRecord[tmp] = a;
        tmp = r;
    }
    return a;
}

int main() {
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif // _DEBUG
    std::ios::sync_with_stdio(false);

    int n,Q; cin >> n;
    for (int i = 0; i < MaxN; ++i)RootRecord[i] = i;//初始化并查集
    while (n--) {
        int k, a, b, fa, fb; cin >> k >> a;
        fa = findRoot(a);
        if (!BirdCounted[a]) {
            ++BirdN;
            BirdCounted[a] = true;
        }
        while (--k) {
            cin >> b; 
            fb = findRoot(b);
            if(fa != fb) RootRecord[fb] = fa;
            if (!BirdCounted[b]) {
                ++BirdN;
                BirdCounted[b] = true;
            }
        }
    }

    for (int i = 1; i <= BirdN; ++i) {
        if (i == findRoot(i))++RootN;
    }
    cout << RootN << " " << BirdN << endl;

    cin >> Q;
    while (Q--) {
        int u, v; cin >> u >> v;
        if (findRoot(u) == findRoot(v))cout << "Yes\n";
        else cout << "No\n";
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值