1118 Birds in Forest (并查集)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤104) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B1​ B2​ ... BK​

where K is the number of birds in this picture, and Bi​'s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

After the pictures there is a positive number Q (≤104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

 分析:使用并查集得到每只小鸟的共同“父节点”,visit数组记录小鸟数目,flag数组通过1-10000标号的"父节点"得到共有多少个不同的”父节点“也就是树的数量。最后判断两只⻦是否在同⼀棵树,只需要知道这两只⻦的”父节点“是否相等即可。

#include<iostream>
#include<string>
#include<algorithm>
#include<vector>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<cmath>
#include<unordered_map>
//1009;
using namespace std;
typedef long long ll;
const int inf = 99999999;
int n, m, k;
int father[10010];
int find(int x) {
	int temp = x;
	while (x != father[x]) x = father[x];
	while (temp != father[temp]){
		int z = temp;
		temp = father[temp];
		father[z] = x;
	}
	return x;
}
void Union(int a, int b) {
	a = find(a);
	b = find(b);
	father[a] = b;
}
bool visit[10010],flag[10010];
int main() {
	int a, b;
	int tree=0, num=0;
	cin >> n;
	for (int i = 0; i <= 10000; i++) father[i] = i;
	while (n--) {
		cin >> k;
		cin >> a;
		if (!visit[a]) {
			num++;
			visit[a] = 1;
		}
		for (int i = 1; i < k; i++) {
			cin >> b;
			if (!visit[b]) {
				num++;
				visit[b] = 1;
			}
			Union(a, b);  
		}
	}
	for (int i = 0; i <= 10000; i++) {
		int x = find(i);
		if (!flag[x] && visit[i]) { //如果i鸟在照片中且其父节点未被查找过
			tree++;
			flag[x] = 1;
		}
	}
	cout << tree << " " << num << endl;
	cin >> m;
	while (m--) {
		cin >> a >> b;
		if (find(a) != find(b)) cout << "No" << endl;
		else cout << "Yes" << endl;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值