hdu 1874 畅通工程序

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1874

题目描述:

某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。

Input

本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。

Output

对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.

Sample Input

3 3

0 1 1

0 2 3

1 2 1

0 2

3 1

0 1 1

1 2

Sample Output

2

-1

思路:套模板解决的,套用了hdu2544,那里有代码思路详细解释

#include<iostream>
#include<cstdio>
#include<queue>
#include<cmath>
#include<cstring>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int maxn=10010,INF=0x3fffff;
int vis[maxn],cnt,d[maxn],head[maxn];
int m,n;
int S,T;
struct node
{
    int u,v,w,next;

}Node[maxn];
void add(int u,int v,int w)
{
    Node[cnt].u=u;
    Node[cnt].v=v;
    Node[cnt].w=w;
    Node[cnt].next=head[u];
    head[u]=cnt++;

}
void spfa(int s)
{
    queue<int>q;
    for(int i=0;i<=n;i++)d[i]=INF;
    d[s]=0;
    mem(vis,0);
    q.push(s);
    vis[s]=1;
    while(!q.empty())
    {
       int u=q.front();
       q.pop();
       vis[u]=0;
       for(int i=head[u];i!=-1;i=Node[i].next)
       {
           node e=Node[i];
           if(d[e.v]>d[e.u]+e.w)
           {
            d[e.v]=d[e.u]+e.w;
             if(!vis[e.v])
             {
                 q.push(e.v);
                 vis[e.v]=1;
             }
           }
       }

    }
    
}



int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        mem(head,-1);
        cnt=0;
        for(int i=1;i<=m;i++)
        {
            int u,v,w;
            cin>>u>>v>>w;
            add(u,v,w);
            add(v,u,w);
        }
        cin>>S>>T;
        spfa(S);
        if(d[T]>=INF)   d[T]=-1;//这一行解决了路线不存在的情况
        cout<<d[T]<<endl;

    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值