hdu 1702 ACboy needs your help again! (栈和队列)

题目链接:https://cn.vjudge.net/problem/HDU-1702

题目描述:

ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.

Sample Input

4

4 FIFO

IN 1

IN 2

OUT

OUT

4 FILO

IN 1

IN 2

OUT

OUT

5 FIFO

IN 1

IN 2

OUT

OUT

OUT

5 FILO

IN 1

IN 2

OUT

IN 3

OUT

Sample Output

1

2

2

1

1

2

None

2

3

目的:这道题主要就是考察队列的先进先出栈的先进后出的特性。另外注意数据的输入方式。

代码如下:

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<queue>
#include<stack>
using namespace std;
int main()
{
    int T, n, m;
    char s[5], ch[3];
    while(scanf("%d",&T)!=EOF)
    {
        while(T--)
        {
           scanf("%d%s",&n,s);
           if(s[2]=='F')//先确定是用队列还是用栈//这里为队列
           {
            queue<int>Q;//若是把这句话放在while(n--)内是不对的,所以才会每次都输出None
              while(n--)
              {

                scanf("%s",ch);
                if(ch[0]=='I')//这里确定是In还是Out//这里In
                {
                    scanf("%d",&m);
                    Q.push(m);//不要忘记将m进队列
                }
                else//这里Out
                {
                    if( Q.empty())//如果队列为空就输出None
                      cout<<"None"<<endl;
                     else//不空就根据规则输出
                     {
                        printf("%d\n",Q.front());
                        Q.pop();//输出的数要出列
                     }
                }

              }
           }
           else//这里为栈  //接下来的就根据队列的来访造就行
           {
               stack<int>S;//不过要把队列改为栈
              while(n--)
              {

                scanf("%s",ch);
                if(ch[0]=='I')
                {
                    scanf("%d",&m);
                    S.push(m);
                }
                else
                {
                    if(S.empty())
                      cout<<"None"<<endl;
                     else
                     {
                        printf("%d\n",S.top() );
                        S.pop();
                     }
                }
              }
           }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值