POJ 3616 Milking Time

题目描述:

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houriN), an ending hour (starting_houri < ending_houriN), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ RN) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: N, M, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

题目分析:

输入n,m,t,n表示一共可以挤奶的时间,m表示可以挤奶的次数,接下来m行代表挤奶时间以及奶量,t表示每挤一次奶需要休息的时间,求最大挤奶量。

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<cmath>
#include<algorithm>
using namespace std;
int dp[10010];//dp[i]表示第i个时间段挤奶能够得到的最大值
struct node
{
    int fr, ed, h;
}s[10010];

int cmp( node a, node b)
{
    if(a.fr==b.fr)
        return a.ed<b.ed;

    return a.fr<b.fr;
}

int main()
{
    int n, m, t;
    while(scanf("%d%d%d",&n,&m,&t)!=EOF)
    {
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&s[i].fr,&s[i].ed,&s[i].h);
           // s[i].ed+=t;
        }
        sort(s,s+m,cmp);

        for(int i=0;i<m;i++)
            dp[i]=s[i].h;
        for(int i=0;i<m;i++)
            for(int j=0;j<i;j++)
 //如果i区间的开始时间>=i-1个区间里的有某个区间的结束时间+休息时间,比较。         
                if(s[i].fr>=s[j].ed+t)   
//第i个时间段挤奶的最大值 = 前 i – 1 个时间段挤奶最大值中的最大值 + 第i次产奶量。     
                     dp[i]=max(dp[i],dp[j]+s[i].h);

        int maxn=0;
        for(int i=0;i<m;i++)
            maxn=max(maxn,dp[i]);

        printf("%d\n",maxn);
    }
    return 0;
}

 

链接

定义dp[i]表示第i个时间段挤奶能够得到的最大值,拆开来说,就是前面 i – 1个时间段任取0到i – 1个时间段挤奶,然后加上这个时间段(i)的产奶量之和。dp[i]满足如下递推关系:

第i个时间段挤奶的最大值 = 前 i – 1 个时间段挤奶最大值中的最大值 + 第i次产奶量。

注意此处的第i个时间段不等同于第i次。

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值