POJ - 3616 Milking Time

传送门: 点击打开链接
Milking Time
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12045 Accepted: 5081

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

基础dp

先按照(beg, end, eff)中的beg从小到大排序,然后遍历各个时间段,对于每个时间段,认为该时间段用来挤奶,然后遍历该时间段之前的能够与该时间段共同挤奶的时间段,进行状态转移

状态转移公式:dp[i] = (for each j < i且j满足题干条件) max(dp[i], dp[j] + a[i].ef)

哦对了 不要忘记每个dp[i]初始化为a[i].ef 因为有的时间段可能找不到前一个状态,即之前的时间段不能与该时间段一起挤奶

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdlib>
using namespace std;
typedef long long ll;
typedef pair<int, int>P;
const int N = 1000000 + 5;
const int inf = 0x3f3f3f3f;
const int M = 1000 + 5;
struct node
{
    int beg, en, ef;
}a[M];
int dp[M], rec[M];
bool cmp(const node&p, const node&q)
{
    if(p.beg == q.beg) return p.en < q.en;
    return p.beg < q.beg;
}
int main()
{
    int n, m, r;
    scanf("%d%d%d", &n, &m, &r);
    for(int i = 0; i < m; i++)
    {
        scanf("%d%d%d",&a[i].beg, &a[i].en, &a[i].ef);
    }
    sort(a, a + m, cmp);
    int maxi = -1;
    for(int i = 0; i < m; i++)
    {
        dp[i] = a[i].ef;
        for(int j = i - 1; j >= 0; j--)
        {
            if(a[j].en <= a[i].beg - r)
                dp[i] = max(dp[i], dp[j] + a[i].ef);
        }
        maxi = max(maxi, dp[i]);
    }
    printf("%d\n", maxi);
}

下面普及一种错误思想,这种dp思想很难发现错误,我就是这么wa了好多发(一下献给如我一样的dp新手)

我将dp[i]认为成遍历到时间段i是的最大值(其中时间段i可以挤奶也可以不挤奶)

因此 如果i无前状态,即之前的时间段没有能和i一起挤奶的dp[i] = max(dp[i-1], a[i].ef)

如果有前状态,则dp[i] = max(dp[i-1], a[i].ef + dp[rec[i]]) (此处的rec[i]指的是与i能一起挤奶的最晚时间段)

但是我忽略了一个细节,比如下面这个例子

100 3 2
0 100 1000
2 4 10

10 20 100

输出了1100... 因为dp[1]其实是1时间段没有挤奶而0时间段挤奶的值,为1000;但是2时间段认为自己能和1一起挤奶,但是2时间段是在0时间段之内的(虽然排序后0在2前)

因此,这个看起来很正确的算法有一个潜在错误:如果有时间段包含,则无法准确计算

下面是错误代码,请以此为戒

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdlib>
using namespace std;
typedef long long ll;
typedef pair<int, int>P;
const int N = 1000000 + 5;
const int inf = 0x3f3f3f3f;
const int M = 1000 + 5;
struct node
{
    int beg, en, ef;
}a[M];
ll dp[M];
int rec[M];
bool cmp(const node&p, const node&q)
{
    if(p.beg == q.beg) return p.en < q.en;
    return p.beg < q.beg;
}
int main()
{
    int n, m, r;
    scanf("%d%d%d", &n, &m, &r);
    for(int i = 0; i < m; i++)
    {
        scanf("%d%d%d",&a[i].beg, &a[i].en, &a[i].ef);
    }
    sort(a, a + m, cmp);
    cout << endl;
    for(int i = 0; i < m; i++)
        cout << a[i].beg << " " << a[i].en << " " << a[i].ef << endl;
    memset(rec, -1, sizeof(rec));
    for(int i = 0; i < m; i++)
    {
        for(int j = i - 1; j >= 0; j--)
        {
            if(a[j].en <= a[i].beg - r)
            {
                rec[i] = j;
                break;
            }
        }
    }
    cout << endl;
    for(int i = 0; i < m; i++)
        cout << "rec[" << i << "] = " << rec[i] << endl;
    memset(dp, -1, sizeof(dp));
    dp[0] = (ll)a[0].ef;
    for(int i = 1; i < m; i++)
    {
        if(rec[i] != -1)
        {
            dp[i] = max(dp[i-1], dp[rec[i]] + (ll)a[i].ef);
        }
        else
            dp[i] = max(dp[i-1], (ll)a[i].ef);
    }
    printf("%lld\n", dp[m - 1]);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值