hdu 1865

Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.
 

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
 

Output
The output contain n lines, each line output the number of result you can get .
 

Sample Input
  
  
3 1 11 11111
 

Sample Output
  
  
1 2 8
 

Author
z.jt
 

Source

//解题思路:

          观察规律可得到次数列为斐波纳契数列f(i)=f(i-1)+f(i-2),但是由于最大数列有200项,即使是64位表示也会溢出的,

      解决此问题方法就是采用大数模拟相加。

      定义二维数组

#include<stdio.h>
#include<string.h>
 int main()
   {
   	 int n;
   	 int i,j;
   	 int len ;
   	 int jinwei;
   	 int temp;
   	 int len1,len2,len3,len4;
   	 char num[200];
   	 int  p[220][1000]={0};
    	 
   	 scanf("%d",&n);
   	 while(n--)
   	   {
   	   	  scanf("%s",num);
   	   	  len=strlen(num);
   	   	  if(len==1)
   	   	    {
   	   	    	 printf("1\n");
   	   	    	 continue;
   	   	    }
   	   	  if(len==2)
   	   	    {
   	   	    	 printf("2\n");
   	   	    	 continue;
   	   	    }
   	   	  memset(p,0,sizeof(p));
   	     <span style="color:#ff0000;"> p[1][0]=1;
   	      p[2][0]=2;
		  len3=0;
		 for(i=3;i<=len;i++)
		   {
		     jinwei=0;
		   	   for(j=0;j<=len3;j++)
		   	      {
		   	      	  temp=p[i-1][j]+p[i-2][j]+jinwei;
		   	      	  jinwei=temp/10;
		   	      	  p[i][j]=temp%10;
		   	      	if(j==len3&&jinwei!=0)
		   	      	   len3++;
		   	      }
		   }</span>
		   while(p[len][len3]==0)  len3--;
		     for(;len3>=0;len3--)
		       printf("%d",p[len][len3]);
		    printf("\n");
   	   }
   	return 0;
   } 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值