hdu1372 Knight Moves (bfs)

题目链接:https://cn.vjudge.net/contest/271475#problem/A

题目描述:

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

题目大意:

下象棋,遵循”马走日“的规则,在每个格,一共可以走8个方向。如下图所示:

代码:

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
#include<iostream>
using namespace std;
int go[8][2]={{-1,2},{2,-1},{1,2},{2,1},{-1,-2},{1,-2},{-2,1},{-2,-1}};
char a[3],b[3];
int vis[10][10];
int sx,sy,ex,ey;
struct node
{
    int x,y,step;
};
/*int check(int x,int y)
{
    if(x>=0&&y>=0&&x<8&&y<8&&vis[x][y]!=1)
        return 1;
}*/
int bfs(int sx,int sy)
{
    queue<node>Q;
    node n,m,q;
    n.x=sx;
    n.y=sy;
    n.step=0;
    memset(vis,0,sizeof(0));
    vis[n.x][n.y]=1;
    Q.push(n);
    while(!Q.empty())
    {
        q=Q.front();
        Q.pop();

        if(q.x==ex&&q.y==ey)

            return q.step;


        for(int i=0;i<9;i++)
        {
             m.x=q.x+go[i][0];//判断走完后是否越界
              m.y=q.y+go[i][1];

           // if(q.x>=0&&q.y>=0&&q.x<8&&q.y<8&&vis[q.x][q.y]!=1)
            if(m.x<0||m.x>=8||m.y<0||m.y>=8)//错在了这里判断时不需要加上vis[m.x][m.y]是否已使用过,因这一个错误,找了两个晚上的错           
             {
              m.step=q.step+1;
              vis[m.x][m.y]=1;
              Q.push(m);

              //cout<<m.x<<m.y<<ex<<ey<<endl;
               // cout<<m.step<<' ';
             }
        }
    }
    //return 0;
}
int main()
{
    int sum;
   while(scanf("%s%s",a,b)!=EOF)
   {
       //下方先将字符型转化为int型数据
       sx=a[0]-'a';
       sy=a[1]-'1';
       ex=b[0]-'a';
       ey=b[1]-'1';
       sum= bfs(sx,sy);//终点位置可以不用传递,全局变量去定义在bfs()中,直接去调用就行
       printf("To get from %s to %s takes %d knight moves.\n",a,b,sum);
   }
   return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值