POJ-1915 Knight Moves

Knight Moves
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 26185 Accepted: 12342

Description

Background 
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
The Problem 
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
For people not familiar with chess, the possible knight moves are shown in Figure 1. 


Input

The input begins with the number n of scenarios on a single line by itself. 
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

Source

TUD Programming Contest 2001, Darmstadt, Germany
跳马题又双叒叕来了 (ノ・ω・)ノ゙,题意,给出起点和终点,马可以按照如图所示的八种方法跳跃,问马最少需要多少次才能跳到终点,如果无法到达则输出0。

思路:

还是BFS,创建一个step数组存储步数,开始初始化为0,若到达不了该点的step值为0,创建一个visit数组,用于存储该点是否被访问过,对于每个点,分别朝八个方向跳,如果坐标合法且没访问过,则加入队列,步数在原有基础上+1,修改此位置为已访问,否则不操作。最后输出结果即可。

#include<iostream>
#include<cstring>
#include<queue>
#define MAX 400
using namespace std;
int dir[8][2]={{1,2},{1,-2},{2,1},{2,-1},{-1,2},{-1,-2},{-2,1},{-2,-1}};
int sx,sy,ex,ey;
int i;
int n;
int ans;
bool visit[MAX][MAX];
int step[MAX][MAX];
struct node
{
    int x, y;
};
queue <node> q;
void bfs(int x,int y)
{
    node t;
    t.x=x;t.y=y;
    q.push(t);
    while(!q.empty())
    {
        t=q.front();
        q.pop();
        if(t.x==ex&&t.y==ey)
        {
            ans=step[t.x][t.y];
            return ;
        }
        for(i=0;i<8;i++)
        {
            node te;
            te.x=t.x+dir[i][0];
            te.y=t.y+dir[i][1];
            if(te.x<0||te.y<0||te.x>=n||te.y>=n)    continue;
            if(!visit[te.x][te.y])
            {
                visit[te.x][te.y]=true;
                step[te.x][te.y]=step[t.x][t.y]+1;
                q.push(te);
            }
        }
    }
}
int main()
{
    int t;
    cin >>t;
    while(t--)
    {
        cin >>n;
        cin >>sx>>sy>>ex>>ey;
        while(!q.empty())   q.pop();
        memset(step,0,sizeof(step));
        memset(visit,false,sizeof(visit));
        bfs(sx,sy);
        cout << ans << endl;
    }
    return 0;
}




  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值