Sumsets

Sumsets

Time Limit : 6000/2000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 16   Accepted Submission(s) : 12
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6
分析:
本题是一道规律题,分两种情况,一种是奇数时,很明显此时,但是偶数是找不到,网上看了大神的代码,看不懂,待日后理解。
代码:
#include<stdio.h>
__int64 a[1000010];
void f()
{
	int i,j,k;
	a[1]=1;
	a[2]=2;
	for(i=3;i<1000010;i++)
	{
		if(i%2)
        a[i]=a[i-1];
		else a[i]=a[i-2]+a[i/2];
		a[i]%=1000000000;		
	}
}
int main()
{
	__int64 n;
	f(); //dabiao
	while(~(scanf("%I64d",&n)))
	{
		printf("%I64d\n",a[n]);
		
	}
	return 0;
}
方法二:
动态规划:网上看的,不懂,粘下来慢慢理解。
状态:
d[i][j]表示前i个二的幂数凑成数j的方法数
空间可以降维到d[j]
状态转移方程:
d[j]=d[j]+d[j-c[i]]
c[i]=2^i
边界:
d[0]=1
代码:
#include<cstdio>


int d[1000005],c[25],n,i,j;
int main()
{
scanf("%d",&n);
c[0]=d[0]=1;
for(i=1;i<=20;i++)
c[i]=c[i-1]<<1;
for(i=0;i<=20&&c[i]<=n;i++)
for(j=c[i];j<=n;j++)
d[j]=(d[j]+d[j-c[i]])%1000000000;
printf("%d/n",d[n]);
}
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值