Fibonacci Numbers
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1967 Accepted Submission(s): 771
Problem Description
The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively zero and one.
What is the numerical value of the nth Fibonacci number?
What is the numerical value of the nth Fibonacci number?
Input
For each test case, a line will contain an integer i between 0 and 10
8 inclusively, for which you must compute the ith Fibonacci number fi. Fibonacci numbers get large pretty quickly, so whenever the answer has more than 8 digits, output only the first and last 4 digits of the answer, separating the two parts with an ellipsis (“...”).
There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).
There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).
Sample Input
0 1 2 3 4 5 35 36 37 38 39 40 64 65
Sample Output
0 1 1 2 3 5 9227465 14930352 24157817 39088169 63245986 1023...4155 1061...7723 1716...7565
Source
Recommend
分析:本题是一道大数问题,中间涉及到一些东西,如找循环节,mod运算。思路很清楚,当n<40时,按照普通的斐波那契方法就行了,当n》40时,分别求前四位和后四位,后四位对10000取余即可,需注意的是,本题需要找循环节,因为开10的8次方的数组会超内存(实践得到的),至于前四位的求法,需借助
Fibonacci的
通项公式
——
f(n)=1/sqrt(5)(((1+sqrt(5))/2)^n+((1-sqrt(5))/2)^n)
f(n)=1/sqrt(5)(((1+sqrt(5))/2)^n+((1-sqrt(5))/2)^n)
代码:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
int d[16000];
void a()
{
int i;
d[0]=0;d[1]=d[2]=1;
for(i=3;i<40;i++)
d[i]=d[i-1]+d[i-2];
}
void b()
{
int i;
for(i=40;i<16000;i++)
{
d[i]=(d[i-1]%10000+d[i-2]%10000)%10000; //快速幂乘法至今不理解!!
}
}
int first(int n)
{
double ans;
ans=n*log10(0.5+0.5*sqrt(5.0))-0.5*log10(5.0);
ans=ans-(int)ans;
ans=pow(10.0,ans);
while(ans<1000)
ans*=10;
return (int)ans;
}
int main()
{
int i,n,m;
a();
b();
while(scanf("%d",&n)!=EOF)
{
if(n<40)
printf("%d\n",d[n]);
else{
printf("%d",first(n));
printf("...%.4d\n",d[n%15000]);
}
}
return 0;
}
#include<string.h>
#include<stdlib.h>
#include<math.h>
int d[16000];
void a()
{
int i;
d[0]=0;d[1]=d[2]=1;
for(i=3;i<40;i++)
d[i]=d[i-1]+d[i-2];
}
void b()
{
int i;
for(i=40;i<16000;i++)
{
d[i]=(d[i-1]%10000+d[i-2]%10000)%10000; //快速幂乘法至今不理解!!
}
}
int first(int n)
{
double ans;
ans=n*log10(0.5+0.5*sqrt(5.0))-0.5*log10(5.0);
ans=ans-(int)ans;
ans=pow(10.0,ans);
while(ans<1000)
ans*=10;
return (int)ans;
}
int main()
{
int i,n,m;
a();
b();
while(scanf("%d",&n)!=EOF)
{
if(n<40)
printf("%d\n",d[n]);
else{
printf("%d",first(n));
printf("...%.4d\n",d[n%15000]);
}
}
return 0;
}