Fibonacci NumbersTime

题目地址:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1828

Time Limit: 2 Seconds      Memory Limit: 65536 KB

A Fibonacci sequence is calculated by adding the previous two members of the sequence, with the first two members being both 1.

f(1) = 1, f(2) = 1, f(n > 2) = f(n - 1) + f(n - 2)

Your task is to take a number as input, and print that Fibonacci number.


Sample Input

100


Sample Output

354224848179261915075


Note:

No generated Fibonacci number in excess of 1000 digits will be in the test data, i.e. f(20) = 6765 has 4 digits.

 

考察高精度运算

关键点是求每一位相加后的数字,并且还应该保证在输出的时候尽可能的方便

这个时候关键点就是对a[i][j]进行对10取余,这样就保证了数组正序存放的数是逆序的数据

这道题竟然是多组输入,找了 很久BUG,发现是输出错误~~~~~~

#include<algorithm>
#include<cstring>
#include<cmath>
#include<iostream>
#include<cstdio>
using namespace std;
int a[5010][1010];
void init()
{
    a[1][0]=1;
    a[2][0]=1;
    for(int i=3; i<=5001; ++i)
    {
       int c=0;
       for(int j=0;j<=1001;++j)
       {
           a[i][j]=(a[i-1][j]+a[i-2][j]+c)%10;
           c=(a[i-1][j]+a[i-2][j]+c)/10;
       }
    }
}
int main()
{
    init();
    int n;
    while(~scanf("%d",&n))
    {
    int i;
    for(i=1001;i>=0;--i)
        if(a[n][i]!=0)
            break;
    for(;i>=0;--i)
    {
        printf("%d",a[n][i]);
    }
    printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值