Pick-up sticks(线段相交)

Pick-up sticks
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 14393 Accepted: 5450

Description
Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.

Input
Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.

Output
For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown.

The picture to the right below illustrates the first case from input.

Sample Input

5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0

Sample Output

Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.

Hint
Huge input,scanf is recommended.

Source
Waterloo local 2005.09.17

#include <iostream>
#include <algorithm>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <set>
using namespace std;
const double eps = 1e-8;
int cmp(double x)
{
    if(fabs(x)<eps)
        return 0;
    if(x>0)
        return 1;
    return -1;
}
const double pi = acos(-1.0);
struct point
{
    double x, y;
    int id;
    point() {}
    point(double a, double b)
    {
        x = a;
        y = b;
    }
    friend point operator + (const point &a, const point &b)
    {
        return point (a.x + b.x, a.y + b.y);
    }
    friend point operator - (const point &a, const point &b)
    {
        return point (a.x - b.x, a.y - b.y);
    }
} Point[622000];
double dot(const point &a, const point &b)//点积
{
    return a.x*b.x+a.y*b.y;
}
double det(const point &a, const point &b)//叉积
{
    return a.x*b.y - a.y*b.x;
}
struct line
{
    point a, b;
    line() {};
    line(point x, point y):a(x), b(y) {}
} Line[322000];
line point_make_line(const point a, const point b)
{
    return line(a, b);
}
bool PointOnSegment (point p, line A)
{
    return cmp(det(A.a - p, A.b-p))==0&&cmp(dot(A.a-p, A.b-p))<=0;
}
bool line_make_point(line l1, line l2)
{
    if (PointOnSegment(l1.a, l2) || PointOnSegment(l1.b, l2) || PointOnSegment(l2.a, l1) || PointOnSegment(l2.b, l1))
    {
        return true;
    }
    double c1 = det(l1.a - l2.a, l1.a - l1.b);
    double c2 = det(l1.a - l2.b, l1.a - l1.b);
    double c3 = det(l2.a - l1.a, l2.a - l2.b);
    double c4 = det(l2.a - l1.b, l2.a - l2.b);
    return cmp(c1) * cmp(c2) < 0 && cmp(c3) * cmp(c4) < 0;
}
bool flag[100010];
int main()
{
    int n;
    double x1,y1,x2,y2;
    while(scanf("%d",&n)==1 && n)
    {
        for(int i = 1; i <= n; i++)
        {
            scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
            Line[i] = line(point(x1,y1),point(x2,y2));
            flag[i] = true;
        }
        for(int i = 1; i <= n; i++)
        {
            for(int j = i+1; j <= n; j++)
            {
                if(line_make_point(Line[i],Line[j]))
                {
                    flag[i] = false;
                    break;
                }
            }
        }
        printf("Top sticks: ");
        bool first = true;
        for(int i = 1; i <= n; i++)
            if(flag[i])
            {
                if(first)first = false;
                else printf(", ");
                printf("%d",i);
            }
        printf(".\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值