Pick-up sticks

题目:

Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.
Input
Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.
Output
For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown. 

The picture to the right below illustrates the first case from input.
Sample Input
5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0
Sample Output
Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.
Hint
Huge input,scanf is recommended.

思路:

如果这条线段跟它以后的线段没有交点,则它是Top stick。

参考代码:

#include<cstdio> 
#include<iostream>
#include<cstring>
using namespace std;

typedef struct Point{
	double x,y;
}point;

typedef struct Segment{
	point a,b;
}segement;
segement seg[100002];
int fla[100002];

double multiCross(segement seg1,segement seg2)
{
	double flag = 1.0;
	point v1,v2,v3;
	v1.x = seg2.a.x - seg1.a.x;
	v1.y = seg2.a.y - seg1.a.y;
	v2.x = seg2.b.x - seg1.a.x;
	v2.y = seg2.b.y - seg1.a.y;
	v3.x = seg1.b.x - seg1.a.x;
	v3.y = seg1.b.y - seg1.a.y;
	flag = v3.x*v1.y - v3.y*v1.x;
	flag *= (v3.x*v2.y - v3.y*v2.x);
	return flag;
}

bool cross(segement seg1,segement seg2)
{
	if(multiCross(seg1,seg2) <= 0 && multiCross(seg2,seg1) <= 0)
	return true;
	else return false;
	
}

int main()
{
	int n;
	while(scanf("%d",&n)==1 && n)
	{
		memset(fla,1,sizeof(fla));
		for(int i = 1;i <= n;i ++)
		{
			scanf("%lf %lf %lf %lf",&seg[i].a.x,&seg[i].a.y,&seg[i].b.x,&seg[i].b.y);
		}
		for(int i = 1;i <= n;i ++)
		{
			for(int j = i+1;j <= n;j ++)
			{
				if(cross(seg[i],seg[j]))
				{
					fla[i] = 0;
					break;
				}
				
			}
		}
		int i = 1;
		while(!fla[i])
		i ++;
		printf("Top sticks: %d",i);
		for(i++;i <= n;i ++)
		{
			if(fla[i])
			printf(", %d",i);
		}
		printf(".\n");
	}
}




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值