Sublime Text3使用Package Control 报错There Are No Packages Available For Installation

在使用sublime时,有时候我们希望将代码复制出来后仍然是高亮显示,这样我们便需要安装SublimeHighLight插件,在安装SublimeHighLight插件之前,我们应该先安装Package Control插件

1、Package Control插件作用:能够利用这个插件安装很多Sublime的插件!
2、SublimeHighLight插件作用:能让代码更好地展示其高亮性!

我先从网上安装了Sublime Test3,然后3的版本中自带了Package Control插件,于是我便想直接利用自带的这个插件来安装HighLight,结果便报错了:“There Are No Packages Available For Installation”

网上说了挺多原因,简单例举一下:
1、IPV6的问题
2、无法打开网址https://packagecontrol.io/channel_v3.json导致访问不了

简单试一下都不行,最后我经过实验得出原因是:官方提供的Package Control就是不能用。将官方的那个Package Control删除了,自己进行添加Package Control便可以了!

具体步骤:
1、Package Control下载网址:Package Control下载链接
下载之后将其解压后,将解压文件重新命名为:Package Control
严格按照上面明明,首字母记住要大些!!!

2、打开Sublime,点击:首选项->浏览程序包,便会打开一个文件夹!
然后删除这个文件夹中已有的”Package Control文件夹”,将刚才自己下载好的并且重新命名的Package Control复制到该文件夹下,然后重新启动Sublime,这样便可以使用Package Control来安装其他插件了!

这里写图片描述


下面讲解一下如何利用Package Control安装SublimeHighLight插件!!!

添加完Package Control后按快捷键“Ctrl+shift+p”,便会出现下面界面:

这里写图片描述

1、点击Add Repository,然后在右下出弹出的框里填入此网址:
https://github.com/n1k0/SublimeHighlight/tree/python3
并按Enter键

这里写图片描述

2、同样使用快捷键“Ctrl+shift+p”,点击Install Package,然后过一会便会弹出一个界面,在框中输入SublimeHighLight,然后便会出现这一选项,然后点击安装,过一会Sublime左下方便会显示安装成功。然后重启Sublime,SublimeHighLight插件便可以使用了!

这里写图片描述

阅读更多
个人分类: 环境配置
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

Sublime Text3使用Package Control 报错There Are No Packages Available For Installation

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭