12279 - Emoogle Balance

We have a very famous and popular fellow in our problemsetters' panel. He is so famous that his name is immaterial. Some of his admirers have recently given him the nickname 'Emoogle'. Let's stick to that name in our discussion for now. Being such a kind, friendly and generous person as he is, Emoogle is often known to give treats to the other problemsetters. Some times, there is a strange rumor in the air that his treats are mostly due to the fact that, if he is not sparing enough for those treats, 'problems' are likely to be created. But let's not pay heed to such nonsense!

\epsfbox{p4853.eps}

Now, there is another word in the air that this remarkable man is going to get married soon. To observe this special occasion with proper respect, his fellow troublemakers have decided to compile a book named '99 reasons why Emoogle should give us a treat'. Every single reason mentioned in this book is denoted by a number. For example, Emoogle should give us a treat because


1.
If he does not, problems will be created. :)
2.
His giveaway problem has been solved by less than 10 teams in the recent programming contest.
3.
He is going to join a world famous goggles manufacturing company soon.
4.
He has found a ticket of a soccer world cup game while digging his backyard garden in the morning.
5.
He has just got a new Facebook fan club.
6.
Having forgotten about a date with his wife-to-be which collided with a Topcoder SRM (Single Round Match), he participated in the SRM. (May God bless his soul!)
7.
A programming contest (may be this one?) is being arranged celebrating his marriage.
8.
He is getting engaged soon.

..................
99.
Solely because he is the great and kind and sweet Emoogle.


If you have any more ideas about why he should throw a party, we would love to know. Drop us a line at emoogle.party gmail.com.

At this point, Dear brother Emoogle might want to remind us about the number of times he has already thrown a party. Hence we introduce the term Emoogle Balance. This is defined as:


Emoogle Balance = number of times Emoogle is supposed to give a treat
according to the book - number of times he has actually given the treat.

In this problem, we want you to find Emoogle Balance. We also wish that Emoogle Balance always keeps a healthy negative value and may dear brother Emoogle have a very happy married life forever.

Input 

There are around 75 test cases in the input file. Each test case describes a series of events. A test case starts with an integer N (1$ \le$N$ \le$1000) denoting the number of events in this test case. This integer is followed by a line with N integers, each describing an event. These integers have values between 0 and 99 (inclusive). A value between 1 and 99 means a reason for Emoogle's giving a treat has occurred while a 0 means he has given a treat.

The end of input will be denoted by a case with N = 0. This case should not be processed.

Output 

For each test case, print a line in the format, `Case X: Y', where X is the case number and Y is the Emoogle Balance for this case.

Sample Input 

5 
3 4 0 0 1 
4 
2 0 0 0 
7 
1 2 3 4 5 0 0 
0

Sample Output 

Case 1: 1 
Case 2: -2 
Case 3: 3
#include<stdio.h>
int main()
{
	int t,i,m,count=1;
	while(scanf("%d",&t)&&t)
	{
		int ans=0;
		for(i=0;i<t;i++)
		{
			scanf("%d",&m);
			if(m) ans++;
			else ans--;
		}
		printf("Case %d: %d\n",count++,ans);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值