(poj 3259)Wormholes(SPFA)

18 篇文章 0 订阅

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 52412 Accepted: 19506
Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output

Lines 1..F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output

NO
YES
Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
Source

USACO 2006 December Gold

题意:要求判断任意两点都能仅通过正边就互相可达的有向图(图中有重边)中是否存在负权环

分析:判断有向图中是否存在负权环,
这第一做法是bellman—ford算法,直接用二重循环遍历n-1条边,每次对从起点到每个点的最短距离进行松弛操作,再对图中进行一次松弛操作,若有更短的路径,则说明有负权。
但是这样写的时间复杂度是O(e*v),e代表图的边数,v是图的顶点数
容易时间超限,虽然可以在其基础上改动,来减少循环的次数,但还是会消耗较长时间,故用SPFA算法的队列优化,时间复杂度为O(VE),V,
E分别是顶点数和边数。证明详见证明详见维基百科Bellman–Ford algorithm

SPFA:
每个顶点最多入队V-1次,证明详见:http://blog.csdn.net/xiazdong/article/details/8193680

#include<cstdio>
#include<queue>
#include<cstring>
#include<functional>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
const int N=505;
int n,m,W;
struct Edge
{
    int to,w;
    Edge(int x,int y):to(x),w(y) {}
};
int d[N],vis[N],cnt[N];
vector<Edge>G[N];
bool spfa(int src)
{
    queue<int>que;///存储入队的点
    memset(cnt,0,sizeof(cnt));///记录入队次数
    memset(vis,0,sizeof(vis));
    memset(d,INF,sizeof(d));
    d[src]=0;
    vis[src]=1;
    que.push(src);
    while(!que.empty())
    {
        int now=que.front();
        que.pop();
        vis[now]=0;
        for(int i=0; i<G[now].size(); i++)///对点s的出边进行遍历
        {
            int to=G[now][i].to;
            if(d[to]>d[now]+G[now][i].w)///符合三角形不等式性质,进行松弛操作
            {
                d[to]=d[now]+G[now][i].w;
                if(vis[to]==0)
                {
                    vis[to]=1;
                    que.push(to);
                    ++cnt[to];///点e入队次数加1
                    if(cnt[to]>=n)///当入队第n次时就存在负权回路
                        return true;
                }
            }
        }
    }
    return false;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        for(int i=0; i<N; i++)
            G[i].clear();
        int a,b,w;
        scanf("%d%d%d",&n,&m,&W);
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&a,&b,&w);
            G[a].push_back(Edge(b,w));
            G[b].push_back(Edge(a,w));
        }
        for(int i=0; i<W; i++)
        {
            scanf("%d%d%d",&a,&b,&w);
            G[a].push_back(Edge(b,-w));
        }
        if(spfa(1))
            puts("YES");
        else puts("NO");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值