Wormholes SPFA

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES


又没读懂题,,,英文阅读能力有待提高,,,前M个路径是双向前进的,后面W个路径是单向的且是后退的,问能不能提前回到起点,也就是判断负环吧,SPFA,第一次用。。。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>

using namespace std;
const int N = 510;

struct node
{
    int e, t;
};
vector<node> edge[N];
int n, d[N], num[N];
bool vis[N];

bool SPFA()
{
    memset(d, 0x3f, sizeof(d));
    memset(num, 0, sizeof(num));
    memset(vis, 0, sizeof(vis));
    queue<int> q;
    q.push(1);
    vis[1] = 1;
    num[1]++;
    d[1] = 0;
    while(!q.empty())
    {
        int u = q.front();
        q.pop();
        vis[u] = 0;
        for(int i = 0; i < edge[u].size(); i++)
        {
            int v = edge[u][i].e;
            int w = edge[u][i].t;
            if(d[u] + w < d[v])
            {
                d[v] = d[u] + w;
                if(!vis[v])
                {
                    q.push(v);
                    vis[v] = 1;
                    num[v]++;
                    if(num[v] > n) 
                        return true;
                }
            }
        }
    }
    return false;
}
int main()
{
    int f, m, w;
    int u, v, z;
    struct node p;
    scanf("%d", &f);
    while(f--)
    {
        scanf("%d%d%d", &n, &m, &w);
        for(int i = 1; i <= n; i++)
            edge[i].clear();
        while(m--)
        {
            scanf("%d%d%d", &u, &v, &z);
            p.e = v;
            p.t = z;            
            edge[u].push_back(p);
            swap(p.e, u);
            edge[u].push_back(p);
        }
        while(w--)
        {
            scanf("%d%d%d", &u, &v, &z);
            p.e = v;
            p.t = -z;
            edge[u].push_back(p);
        }
        if(SPFA())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值