Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 27921 Accepted Submission(s): 8307
Problem Description
给你n个点,m条无向边,每条边都有长度d和花费p,给你起点s终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。
Input
输入n,m,点的编号是1~n,然后是m行,每行4个数 a,b,d,p,表示a和b之间有一条边,且其长度为d,花费为p。最后一行是两个数 s,t;起点s,终点。n和m为0时输入结束。
(1<n<=1000, 0<m<100000, s != t)
Output
输出 一行有两个数, 最短距离及其花费。
Sample Input
3 2
1 2 5 6
2 3 4 5
1 3
0 0
Sample Output
9 11
Source
浙大计算机研究生复试上机考试-2010年
分析:普通的最短路问题只有一个限制条件,在这里有两个,重载的时候要加上
#include<cstdio>
#include<queue>
#include<vector>
#include<cstring>
using namespace std;
const int INF=0x3f3f3f3f;
const int N=1005;
int n,m,s,t,ppp;
int vis[N];
struct Edge
{
int to;
int w;///长度
int p;///花费
Edge(int x=INF,int y=INF):w(x),p(y) {}
bool operator < (const Edge &m)const
{
if(w!=m.w)
return w>m.w;//先按照长度从小到大排序
return p>m.p;//长度相同按照花费排序
}
} e,ans;
vector<vector<Edge> >G;
void dijkstra()
{
memset(vis,0,sizeof(vis));
priority_queue<Edge>pq;
pq.push(e);
while(!pq.empty())
{
Edge now=pq.top();
pq.pop();
//printf("%d %d %d\n",now.to,now.w,now.p);
if(vis[now.to]) continue;
vis[now.to]=1;
if(now.to==t)
{
printf("%d %d\n",now.w,now.p);
return ;
}
for(int i=0,j=G[now.to].size(); i<j; i++)
{
Edge next;
//printf(" %d\n",j);
next.to=G[now.to][i].to;
if(vis[next.to]) continue;///已在队列中的不重复入队
if(next.w>G[now.to][i].w+now.w)
{
next.w=G[now.to][i].w+now.w;
next.p=G[now.to][i].p+now.p;
}
if(next.w==G[now.to][i].w+now.w&&next.p>G[now.to][i].p+now.p)
next.p=G[now.to][i].p+now.p;
pq.push(next);
}
}
}
int main()
{
while(~scanf("%d%d",&n,&m)&&n&&m)
{
G.clear();
G.resize(n+1);
int a,b,w,p;
for(int i=1; i<=m; i++)
{
scanf("%d%d%d%d",&a,&b,&w,&p);
e.to=b;
e.w=w;
e.p=p;
G[a].push_back(e);
e.to=a;
G[b].push_back(e);///无向边
}
scanf("%d%d",&s,&t);
e.to=s;
e.w=0;
e.p=0;
dijkstra();
}
return 0;
}