【PAT 甲级】1005 Spell It Right (20)(20 分)

题目链接
作者: CHEN, Yue
单位: PAT联盟
时间限制: 400ms
内存限制: 64MB
代码长度限制: 16KB

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10^100^).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345
Sample Output:

one five

思路:
字符串输入,注意输入的数为0的情况。

代码:

#include <iostream>
#include <sstream>
#include <string>
#include <cstdio>
#include <algorithm>
using namespace std;
const int N = 1e3+5;

string str[]={"zero","one","two","three","four","five","six","seven","eight","nine"};
int cal(string s)
{
    int ans=0;
    for(int i=0;s[i];i++)
    {
        ans+=(s[i]-'0');
    }
    return ans;
}
int main()
{
    string ss;
    cin>>ss;
    int ans=cal(ss);
    string s[N];
    int cnt=0;
    while(ans)
    {
        s[cnt++]=str[ans%10];
        ans/=10;
    }
    for(int i=cnt-1;i>=0;i--)
    {
        cout<<s[i];
        if(i) cout<<" ";
    }
    if(!cnt) cout<<"zero";
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值