POJ 3279 Fliptile

Fliptile
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7372 Accepted: 2780
Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0
**题意:**1是黑,0是白,踩一个点,周围四个点都改变,问怎么去踩,才能都给踩成白色,并把哪个地方踩了几次也用矩阵的方法写下来
题解:枚举第一行的所有踩点情况,根据第一行推出下面所有情况,如果有符合的就找最小的,然后。。。题解都在代码里~
网上搜了n个题解,总算是给弄懂了,好累
~~不感觉像bfs

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define INF 500

int n, m, map[20][20], flip[20][20], over[20][20];

int dx[5] = {0, 0, 0, 1, -1};
int dy[5] = {0, 1, -1, 0, 0};
bool check(int x, int y)//判断该点是 1 还是 0 ,因为flip的值将改变原始的值 
{
    int res = map[x][y];//记录map里面原始数据 用于下面的判断该点的最终结果 
    for(int i=0; i<5; i++)判断map[i-1][j]周围有多少个 flip为1, 奇数个相当于改变了,偶数个就是没变 
    {
        int xl = x + dx[i];
        int yl = y + dy[i];
        res += flip[xl][yl];
    }

    return res&1;//判断结果的奇偶性,可判断该点最终是否为 1
}

int solve()//求出第一行确定的情况下的最小操作次数,
{
    int ans = 0;
    for(int i=1; i<n; i++)//从第二行开始 
    {
        for(int j=0; j<m; j++)
        {
            if(check(i-1, j))//根据第一行所枚举的结果来依次判断下面每一行的结果 
            {
                flip[i][j] = 1;//如果上一个点是1,则下一个点改变 
            }
        }
    }
    for(int j=0; j<m; j++)//因为上面判断截止到n-2行,所以检查最后一行是否还有 1  
    {
        if(check(n-1, j))   return INF;
    }
    for(int i=0; i<n; i++)//记录总共改变了多少次,便于判断 
    {
        for(int j=0; j<m; j++)
        {
            ans+=flip[i][j];
        }
    }
    return ans;

}
int main()
{
    while(scanf("%d%d", &n, &m) != EOF)
    {
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                scanf("%d", &map[i][j]);
            }
        }
        int ant = INF;
        for(int i=0; i< (1<<m); i++)//运用 1<<m 可以枚举第一行的所有翻转情况
        {
            memset(flip, 0, sizeof(flip));
            for(int j=0; j<m; j++)// i<<m 保证了枚举的范围 
            {
                flip[0][j] = i>>j&1;//按照二进制的方法枚举出第一行所有的情况 
            }
            int ans = solve();
            if(ans < ant)
            {
                ant = ans;
                for(int i=0; i<n; i++)
                {
                    for(int j=0; j<m; j++)
                    {
                        over[i][j] = flip[i][j];
                    }
                }
            }
        }
        if(ant == INF)
        {
            printf("IMPOSSIBLE\n");
        }
        else
        {
            for(int i=0; i<n; i++)
            {
                for(int j=0; j<m; j++)
                {
                    printf("%d", over[i][j]);
                    if(j < m-1)
                        printf(" ");
                }
                printf("\n");
            }
        }

    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值