POJ 1751

Highways
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%lld & %llu
Submit

Status
Description
The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can’t reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.
Input
The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.
Output
Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.
Sample Input
9
1 5
0 0
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2
Sample Output
1 6
3 7
4 9
5 7
8 3
题意:告诉你n个村庄的坐标,和m个已经联通的路,求联通剩下的最短路
题解:不知道什么算法的,就是并查集,先把给的连好的路连接了,然后再sort从小到大排序, 一个个连接一个个输出就好了

#include <stdio.h>
#include <string.h>
#include <cmath>
#include <algorithm>
using namespace std;
#define M 1001000

int pre[M], n;
bool ok;
struct node
{
    int from, to;
    int val;
};
node no[M];
struct wei
{
    int x, y;
};
wei we[M];
int find(int a)
{
    int r = a;
    while(r != pre[r])
    {
        r = pre[r];
    }
    return r;
}
void join(int x, int y)
{
    int fx = find(x);
    int fy = find(y);
    if(fx != fy)
    {
        pre[fy] = fx;
        ok = true;
    }
}
void init()
{
    for(int i=1; i<=n; i++)
    {
        pre[i] = i;
    }
}
bool cmp(node a, node b)
{
    return a.val < b.val;
}
int main()
{
    int m, num;
    while(scanf("%d", &n) != EOF && n)
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d", &we[i].x, &we[i].y);
        }
        init();
        scanf("%d", &m);
        num = 0;
        int sum;
        for(int i=1; i<=n; i++)
        {
            for(int j=i+1; j<=n; j++)
            {
                sum = (we[i].x-we[j].x)*(we[i].x-we[j].x) + (we[i].y-we[j].y)*(we[i].y-we[j].y);
                no[num].from = i;
                no[num].to = j;
                no[num++].val = sum;
            }
        }
        int from, to;
        for(int i=0; i<m; i++)//已经修好的路
        {
            scanf("%d%d", &from, &to);
            join(from, to);
        }
        int ne = m;
        sort(no, no+num, cmp);
        for(int i=0; i<num; i++)//连接没有修好的
        {
            ok = false;
            join(no[i].from, no[i].to);
            if(ok)
            {
                ne++;
                printf("%d %d\n", no[i].from, no[i].to);

            }
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值