POJ 1065

探讨了在给定一系列木棍的长度和重量的情况下,如何通过合理的排序和选择策略,利用一台木工机器加工这些木棍,以达到最小化的准备时间。问题转化为寻找最优序列,使机器的准备时间最少,采用类似贪心算法的方法解决。
摘要由CSDN通过智能技术生成

题目:

Wooden Sticks

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 27393 Accepted: 11897

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 
(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1 

Sample Output

2
1
3

 

题解:

排序,类似于开会的贪心算法,求出这样的序列有多少个。循环的终止条件是所有木头都处理过。通过index标记当前第一个没有被处理过的木头序号。

 

AC程序:

#include<algorithm>
#include<cstdio>
using namespace std;

struct wood{
    int l;
    int w;
    int flag;
};

struct wood woods[5010];
int n;
int compare(const wood &a, const wood &b){
    if (a.l == b.l) return a.w < b.w;
    else return a.l < b.l;
}

int find(){
    for (int i = 1;i < n;i++){
        if (woods[i].flag == 0){
            return i;
        }
    }
    return -1;
}

int main(){
    int test;
    scanf("%d", &test);
    while(test--){
        scanf("%d", &n);
        for (int i = 0;i < n;i++){
            scanf("%d", &woods[i].l);
            scanf("%d", &woods[i].w);
            woods[i].flag = 0;
        }
        sort(woods, woods+n, compare);
        woods[0].flag = 1;
        int ww = woods[0].w, ll = woods[0].l;
        int ans = 0, index = 0;
        while(1){
            for (int i = index+1;i < n;i++){
                if (woods[i].flag == 0){
                    if (woods[i].l >= ll && woods[i].w >= ww){
                        woods[i].flag = 1;
                        ww = woods[i].w;
                        ll = woods[i].l;
                    }
                }
            }
            ans += 1;
            index = find();
            if (index == -1){
                break;
            }
            else {
                ww = woods[index].w;
                ll = woods[index].l;
                woods[index].flag = 1;
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值