HDOJ 1016 Prime Ring Problem(素数环 - 深搜)

题目

Prime Ring Problem

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 38   Accepted Submission(s) : 23
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

 

 

题目链接

http://acm.hdu.edu.cn/showproblem.php?pid=1016

 

思路

  因为是做深度搜索的专题练习,所以大概思路并不难想,但是在dfs()函数里却不知道以什么为结束条件,看了代码后,修改了一些地方,比如用save数组保存,用num计数,判断结束条件。

 

代码

#include<iostream>
using namespace std;

const int maxn = 20 +10;
int used[maxn];
int a[maxn];
int save[maxn];
int num;//记录当前找到第几个球
int n;

void dfs(int x)
{

	if(num == n-1 && a[x+1] == 0)//递归的结束条件 已经找到了n-1球,并且最后一个数跟1的和也是素数就输出
	{
		cout<<"1";
		for(int i=0; i<n-1; i++)
		{
			cout<<" "<<save[i];
		}
		cout<<endl;
		return ;
	}
	
	for(int j=2; j<=n; j++)
	{
		if(a[j + x] == 0 && used[j] == 0)
		{
			save[num++] = j;//将j保存起来
			used[j] = 1;
			dfs(j);
			used[j] = 0;
			num--;//
		}
	}
		return;

}

int main()
{
	int i,j;
	memset(a, 0, sizeof(a));
	a[0] = 1;
	a[1] = 1;
	for(i=2; i<maxn ;i++)
	{
		if(a[i] != 0)
		{
			continue;
		}

		for(j=i+i; j<maxn ;j=j+i)
		{
			a[j] = 1;
		}
	}


	int count = 0;
	while(cin>>n)
	{
		memset(used, 0, sizeof(used));
		count++;
		num = 0;
		cout<<"Case "<<count<<":"<<endl;
		used[1] = 1;
		if(n == 1)//没考虑到这种情况
		{
			cout<<"1"<<endl;
		}
		else 
			dfs(1);
		cout<<endl;
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值