HDOJ 1016 Prime Ring Problem ( 素数环 && DFS)

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34618    Accepted Submission(s): 15334


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
注 - 此题为:  HDOJ 1016 Prime Ring Problem ( 素数环 && DFS)

思路:   题意       相邻的两个数的和是素数,都从 1 开始,形成一个环。       通过  深搜 (DFS)实现全排列,  由于是从 1 开始, 所以将  1  作为单独的 一个,对后面的进行全排列,去掉相邻和不是素数的序列,最后,判断两端的数与 1  能否形成素数环

已AC代码:

#include<cstdio>
#include<cstring>
#include<cmath>
int s[50],a[50];  // s 存放要取用的数,a 存放已排好的数 
int vis[50];  // 标记 是否已取用 
int n;

bool judgess(int x)   // 判断素数 
{
	for(int i=2;i<=sqrt(x);++i)
		if(x%i==0)
			return false;
	return true;
}

void DFS(int pos)
{
	if(pos>=n-1)
	{
		if( (!judgess(1+a[0])) || (!judgess(1+a[n-2])) )
			return ;       // 判断 1 和 a 的第一个以及最后一个元素 的和 是否是素数 
		printf("1");   // 1 要单独输出 
		for(int i=0;i<n-1;++i)
			printf(" %d",a[i]);
		printf("\n");
	}
	for(int i=0;i<n-1;++i)
	{
		if(!vis[i])
		{
			if(pos != 0 && ( !judgess( a[pos-1]+s[i]) ) )
				continue;    //判断 将要加入的数与前一个数的和是否是素数 
				
			a[pos]=s[i];
			
			vis[i]=1;    // 标记已加入的数 
			DFS(pos+1);
			vis[i]=0;     // 回溯时取消标记 
		} 
	}
}

int main()
{
	int CASE=1;
	while(scanf("%d",&n)!=EOF)
	{
		int i,j;
		for(i=0;i<n-1;++i)
			s[i]=i+2;   // 直接从 2 开始,1 作为单独的数 
		memset(vis,0,sizeof(vis));
		
		printf("Case %d:\n",CASE++);
		DFS(0);    // s 下标为 0 ,从 0 开始 搜索 
		printf("\n");
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值